1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 ImageMagick Not Resizing Images Upon Upload

Discussion in 'Troubleshooting and Problems' started by Rambro, Nov 20, 2014.

  1. Rambro

    Rambro Well-Known Member

    Sizes are set in attachments:


    ImageMagick seems installed on the server (semi-shared (enterprise shared))


    But when I select ImageMagick in the options in Attachments, it bounces all image uploads that it should be resizing, stating that they're too big. When I select GD, it works fine.

  2. Martok

    Martok Well-Known Member

    What image types are you attaching?

    I've noticed that your supported formats doesn't include PNG, nor TIFF. Mine does and supports 214 formats to your 84. I'm not sure if this is relevant.
  3. Rambro

    Rambro Well-Known Member

    I assume the iphone shoots in jpeg. If it wasn't a supported format, wouldn't it bounce back that error message as opposed to the "image is too large" error?
  4. Martok

    Martok Well-Known Member

    I don't think so. ImageMagick is for resizing images, if a file format isn't supported them it won't attempt to resize.

    Anyway if it's an iPhone being used and it is set to shoot JPEG then that won't be the issue.

    ImageMagick does process differently from GD. Is it rejecting all JPEG file uploads no matter the size or just certain ones? If just some, what are their sizes in MB and pixels?
  5. Gromok Hergom

    Gromok Hergom New Member

    I'm not much of an expert, but I know this much, it is possible you have imagemagick installed, but not working because you also need imagemagick PECL installed as well.

    I learnt that lesson with my old vBulletin board. If that is not it, then disregard my post.
  6. Martok

    Martok Well-Known Member

    I believe that Imagick in the OP's screenshot is the PECL extension for ImageMagick, hence it displaying on the phpinfo page.
  7. Mike

    Mike XenForo Developer Staff Member

    Usually when I've seen this it has been a broken ImageMagick install. Unfortunately I don't have specifics, but upgrading ImageMagick and/or the imagick PECL extension (which might need to be recompiled if ImageMagick has changed) generally seems to resolve it.
  8. Rambro

    Rambro Well-Known Member

    Alright, I'll give my host a talking to and report back.
  9. Rambro

    Rambro Well-Known Member

    Update on this - so the host moved me to a new server and I seemingly can upload iPhone screenshots and pictures now with ImageMagick installed. I still can't get animated avatars working though.
  10. The Dark Wizard

    The Dark Wizard Well-Known Member

    Then its still not correctly installed one would assume.

    I just installed ImageMagick for one of my servers and it worked out of the box for my clients.
  11. Rambro

    Rambro Well-Known Member

    This was my thinking. I'm stuck on troubleshooting though.

    Oddly, I did get on gif to sort of work. A very tiny file that showed in the thread view, and on the member card, but not in the profile page or anywhere else.

    Everything else was a no go.
  12. Gromok Hergom

    Gromok Hergom New Member

    Gif's working only with very tiny files?

    Are you on a shared server for something like $5 a month? If that is the case, then yes, they throttle the **** out of upload sizes only limiting it to something under 1 MB. These types of shared server is like, 3,000 people sharing just one server.

    Would not be suprised if it is restricted to just 500 kb or such. Easy enough to upload reasonable sized pics, but with gif's......

    Edit note - On second thoughts, I guess that is not the case or you would have got the message "so and so file is too large" of which you did not mention.
    Last edited: Dec 16, 2014

Share This Page