MG 2.1 images not resizing?

Iggy

Well-known member
hello,
i have just noticed that "attachments" uploaded thru the media gallery are not getting resized?

pretty big issue right?!

they do in posts, but not in gallery.....seems like something which "should be" working....

any ideas?
 

Iggy

Well-known member
thanks for that chris......now just wondering how to resize the uploaded images we missed....how can we do that?

i was going to run a simple imagemagick command but then i noticed they are converted to this .data extension so not sure that would even work..
 

Iggy

Well-known member
resized them manually on the server level....

came back to test just now tho.....gallery did not resize uploaded images i tried :(

i triple checked the settings to be sure the height and width restrictions were there....

it is an admin acct....but the permission is set, that should be resizing them automatically right?
 

Kirby

Well-known member
Assuming that your images are quite big you'll need smth like this (or a higher value) in config.php

PHP:
$config['maxImageResizePixelCount'] = 30000000;
 

Iggy

Well-known member
so......to get images to actually resize in gallery, i need to add this config line that isnt mentioned anywhere? for 30 million pixels?

its not necessarily huge images just anything over what we put in the settings, which, for this test is 1600px...

it seems more like a bug right??
 

Chris D

XenForo developer
Staff member
The config setting is mentioned in the manual and most likely isn't required. It is only required for very large images - we're talking about dimensions in the region of 4,500 x 4,500.

If smaller images are still not being resized, then it will simply be a misconfiguration of permissions and, like anything else, would need analyzing with the Permissions analyzer feature in the Admin CP.
 

Iggy

Well-known member
The config setting is mentioned in the manual and most likely isn't required. It is only required for very large images - we're talking about dimensions in the region of 4,500 x 4,500.

If smaller images are still not being resized, then it will simply be a misconfiguration of permissions and, like anything else, would need analyzing with the Permissions analyzer feature in the Admin CP.

thank you....by that tool i noticed it was an issue of individual user permission that was over riding...
 

Skylined

Well-known member
There isn't any supported way of doing that. You would have to re-upload them from scratch (or just leave them).
Is it possible to download them by FTP, resize them locally and then upload them by FTP?

If that's possible, could you please tell us the path where they're stored?
 

Iggy

Well-known member
for what its worth....we are ending up this by implementing a server level batch compression script...

of the entire, what is it the /data directory if i recall..

beyond the actual compression benefit tho, its a secondary reason, as i always found...any forum or gallery software i tried, bloats images while resizing them for some reason.....xenforo is not different in this regard, so for true optimization it may be best off to batch resize even at the server level....however, for us compressing the padded file seemed suffice.
 

flash84

Active member
There are separate settings for the gallery. The max image width / height is actually controlled by user group permissions.
Thanks! My images weren't resizing either and I noticed the media gallery was ballooning in size. I didn't know there was an image width and height setting for each user group to resize the images.
 

Sabius

Member
I set the permissions as such for the "Registered" user group:
1587914549208.png

Myself, as the administrator, (but still user group of "Registered") tried uploading a file that was 2000px wide and it did not resize down.

What am I missing to get this to work? Over in the attachments section I only had to set the image width like this and the resizing works fine.
 

Sabius

Member
I was incorrect. The images ARE resizing properly. I was thrown off by the metadata being reported in the MG for the image showing the original size metrics, and not the resized metrics:

1587918830410.png

Actual resized image on disk is about 167k, not 443k. I guess metadata is not updated when resized.
 
Top