• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 How To Remove User Permissions?

DRE

Well-known member
#1
These members STILL show up under User Permissions even though I changed all their user permissions to "Not Set (No)" Some were former moderators, some were users who had certain privileges taken away. This has become an issue for me due to this related issue.

permissions.png

That's not all of em, just a couple.
 

DRE

Well-known member
#5
Then they still have custom permissions or it's an add-on issue.
If I disable all addons and go to User Permissions again will they still show under user permissions?

Because the only addon I've ever revoked for some members is the Taigachat box and that is showing as set to Not Set.
 

Martok

Well-known member
#8
Integer permissions will use the highest number set across all usergroups that someone is in. So if they are in 4 usergroups with 0, 5, 2 and 1 set in these then 5 will be applied. You'll therefore have to look at all of your usergroups again to check.
 

DRE

Well-known member
#9
Integer permissions will use the highest number set across all usergroups that someone is in. So if they are in 4 usergroups with 0, 5, 2 and 1 set in these then 5 will be applied. You'll therefore have to look at all of your usergroups again to check.
wtf, so basically if I said they can only have an avatar that's 51200 something in their highest user group, I then have to set their user permission to be the same?
 

Martok

Well-known member
#10
wtf, so basically if I said they can only have an avatar that's 51200 something in their highest user group, I then have to set their user permission to be the same?
No, it takes the highest number from groups and individual user permissions.
 

Liam W

Well-known member
#12
This doesn't make any sense to me so I'll just remove all secondary usergroups and make their permissions match the primary. Will that work?
You have to make everything in user permissions 'not set'. Everything including integer permissions.
 

DRE

Well-known member
#15
Well this works for all users who are not moderators. So basically the issue that remains now is that I am unable to remove members who were once moderators.
 

Martok

Well-known member
#16
Integer permissions really aren't that difficult.

For your primary group (which should be the Registered group) you set the value you want (which may be 0 if you don't want them to have that permission). For your secondary groups you leave the permission set at 0 unless you want them to have higher value for that permission.

So for example, my Registered group has an avatar size set to 51200. All other groups are set to 0 except for a Promoted group that has it set to 102400. So everyone on the site in whichever group they are in has avatars of 51200 except the Promoted group which can have 102400.
 

WCFA

Active member
#19
I find I am running into this same issue. A member is set to zero and remains in the custom user permissions list.
They stay in the list even though there are no custom settings.
 
#20
Same here for me on XF1.4
I have one member remaining in the custom user permissions list.
All its value are set to "Not set" or "0".