1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 host doesn't allow connection

Discussion in 'Troubleshooting and Problems' started by DRaver, Dec 23, 2014.

  1. DRaver

    DRaver Active Member


    Zend_Mail_Protocol_Exception: host doesn't allow connection - library/Zend/Mail/Protocol/Imap.php:109
    Generiert durch: Unbekanntes Benutzerkonto, Vor 5 Minuten
    #0 /var/www/my-site/library/Zend/Mail/Storage/Imap.php(273): Zend_Mail_Protocol_Imap->connect('mail.my-site...', 25, false)
    #1 /var/www/my-site/library/XenForo/Model/EmailBounce.php(292): Zend_Mail_Storage_Imap->__construct(Array)
    #2 /var/www/my-site/library/XenForo/Deferred/EmailBounce.php(19): XenForo_Model_EmailBounce->openBounceHandlerConnection()
    #3 /var/www/my-site/library/XenForo/Model/Deferred.php(256): XenForo_Deferred_EmailBounce->execute(Array, Array, 7.9999988079071, '')
    #4 /var/www/my-site/library/XenForo/Model/Deferred.php(390): XenForo_Model_Deferred->runDeferred(Array, 7.9999988079071, '', false)
    #5 /var/www/my-site/library/XenForo/Model/Deferred.php(335): XenForo_Model_Deferred->_runInternal(Array, NULL, '', false)
    #6 /var/www/my-site/deferred.php(23): XenForo_Model_Deferred->run(false)
    #7 {main}
    Benötigter Status
    array(3) {
      ["url"] => string(40) "http://www.my-site.de/deferred.php"
      ["_GET"] => array(0) {
      ["_POST"] => array(3) {
        ["_xfRequestUri"] => string(43) "/thema/eure-erfahrungen-mit-traumeel.19702/"
        ["_xfNoRedirect"] => string(1) "1"
        ["_xfResponseType"] => string(4) "json"
    The data for the bouce mail ist correct. I can send mails to this adresse. Or is that another problem?
  2. rainmotorsports

    rainmotorsports Well-Known Member

    Is it a new VPS or something? I've seen some providers disable site out for the first week due to potential spammers signing up to send spam. Blocking I map connections outbound seems a little weird.
  3. DRaver

    DRaver Active Member

    bounce and normal email are on the same server.
  4. Floren

    Floren Well-Known Member

    My error message, I have the same issue:
    Zend_Mail_Protocol_Exception: host doesn't allow connection - library/Zend/Mail/Protocol/Imap.php:109
    Generated By: Unknown Account, 43 minutes ago
    Stack Trace
    #0 /var/www/html/library/Zend/Mail/Storage/Imap.php(273): Zend_Mail_Protocol_Imap->connect('smtp.gmail.com', 587, 'TLS')
    #1 /var/www/html/library/XenForo/Model/EmailBounce.php(292): Zend_Mail_Storage_Imap->__construct(Array)
    #2 /var/www/html/library/XenForo/Deferred/EmailBounce.php(19): XenForo_Model_EmailBounce->openBounceHandlerConnection()
    #3 /var/www/html/library/XenForo/Model/Deferred.php(256): XenForo_Deferred_EmailBounce->execute(Array, Array, 7.9999990463257, '')
    #4 /var/www/html/library/XenForo/Model/Deferred.php(390): XenForo_Model_Deferred->runDeferred(Array, 7.9999990463257, '', false)
    #5 /var/www/html/library/XenForo/Model/Deferred.php(335): XenForo_Model_Deferred->_runInternal(Array, NULL, '', false)
    #6 /var/www/html/deferred.php(23): XenForo_Model_Deferred->run(false)
    #7 {main}
    I thought first is related to Selinux, but it is not. @Mike, I set a Google apps account with specific password, as I use two-steps authentication. I can login fine to it and use the same account on other applications without issues.

    Do I need to use smtp or imap.gmail.com:993? I cannot find anything related into documentation.
    Last edited: Dec 26, 2014
  5. DaveL

    DaveL Well-Known Member

    @DRaver ,

    Did you ever solve this? Ive just enabled bounced emails and im getting the same server error as you did.
  6. DRaver

    DRaver Active Member

  7. DaveL

    DaveL Well-Known Member

  8. Mike

    Mike XenForo Developer Staff Member

    It happens if the IMAP server doesn't give the correct "OK" response. In the first example, I see what appears to be a reference to port 25 which is the SMTP port, not the IMAP port so that may be why. Similarly, Gmail's IMAP port is 993 so it's probably the same issue there.

    So check the port.
    DaveL likes this.
  9. DaveL

    DaveL Well-Known Member

    Thanks Mike. Ive been using port 26, so have asked my host what port number I should use for IMAP. Hopefully that will solve it. (y)

    @DRaver - Hopefully Mike's post will help solve it for you as well.
  10. DRaver

    DRaver Active Member

    Give me a sign if that works.

Share This Page