XF 1.5 Guest Viewing forum Error Page. Any Solution ?

Hello,
I seen on my current visitors list ,users viewing error page (This member is viewing invalid page or a page they don't have a permission to view it.)
Any solution for it? i mean auto redirection add on to main forum list?

Screenshot -
To view this content we will need your consent to set third party cookies.
For more detailed information, see our cookies page.
 
Last edited:

Brad Padgett

Well-known member
Are they actually viewing an error or does it just say that?

I've noticed issues on my forum as well when people are viewing errors including google when they don't actually see an error. I know this because it said the same thing for my super moderator when he was online. Which there isn't any way he would be viewing an error. Google was viewing them too but I'm not sure what it all means or why this was happening.
 
Last edited:

Chris D

XenForo developer
Staff member
There's no add-on for such things, nor would Google appreciate it. If one of their crawlers ends up on an error, it needs to be reported to them as such.

Even though these are listed as guests, it's a high possibility they are actually some sort of Robot or crawler and they've ended up on a valid page that either did exist and no longer does or a page they're not supposed to see.

What the guest user will actually be seeing in most cases, rather than an actual error page, is the log in / sign up page.

This applies to you too @Brad Padgett -- if you see a user there they will indeed be viewing some sort of error. If it's a logged in user, they'll be seeing an error rather than a login page.
 

Brad Padgett

Well-known member
There's no add-on for such things, nor would Google appreciate it. If one of their crawlers ends up on an error, it needs to be reported to them as such.

Even though these are listed as guests, it's a high possibility they are actually some sort of Robot or crawler and they've ended up on a valid page that either did exist and no longer does or a page they're not supposed to see.

What the guest user will actually be seeing in most cases, rather than an actual error page, is the log in / sign up page.

This applies to you too @Brad Padgett -- if you see a user there they will indeed be viewing some sort of error. If it's a logged in user, they'll be seeing an error rather than a login page.

I appreciate your reply. I don't think anythings wrong with the software which is not what I've implied. I just don't see much of a reason for my super moderator for example which I was speaking to at the time to see an error however I did not ask him directly when seeing it. Overall, it's not a problem in my book anyhow. I'm glad you all have done such a good job on xenforo 2 and the error doesn't really bother me.

However, since XF2 URL structures are the same as Xenforo 1 I'm not sure what the error could be. For example Google was viewing a new post I made as an error after moving to XF2. So I'm not quite sure how it could come up with that error. The posts were obviously made after the switch and there's no reason the bot or anyone should see an error.

I just recently updated my site to HTTPS and SSL but that was only tonight. This has been happening since I upgraded. Thank you anyways.

EDIT: Just wanted to update this. It's not as frequent as it appears in the Thread Starters image. Not as frequent but it happens with posts that have been made 'after' the upgrade.
 
Last edited:
Top