1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 google search results

Discussion in 'Troubleshooting and Problems' started by Pierre Boulanger, Sep 23, 2013.

  1. Pierre Boulanger

    Pierre Boulanger Active Member

    Hi,

    I in xenforo about 2 months now and very happy of course. I'm facing a problem with my forum visibility on the Internet though. In my previous php.bb board almost all results referring to Citroen 2cv and historic Citroen cars (thats my forum is all about) in Greek appeared first in search result. Now there is nothing.

    I noticed also in google analytics that there are no results in "recent keywords" option or in "top keywords.

    Can you help me with this?

    A final question,
    For some reason i lost all the "Likes" in fb and google+ in "Share this page" feature. What could be possibly went wrong?

    The story of a legend.jpg
     
  2. Adam Howard

    Adam Howard Well-Known Member

    You'll be happy to know I found your domain. So Google has not forsaken you. But any time you switch forum software, you're going to take a hit in SEO rating. And because you're not using a common top level domain name (you're using .gr ), your hit is going to be even greater (Google seems to prefer .com .net .org .info .gov .edu .eu .uk). But rest assured it will bounce back over time.

    As for your likes and shares, you need to configure your social media in your Admin CP so it can be associated with your site.
     

    Attached Files:

    Pierre Boulanger likes this.
  3. Mike

    Mike XenForo Developer Staff Member

    Also regarding the likes and shares, any time you change URLs (such as moving software), you won't see the existing data (as they're tied to URL).
     
    Adam Howard likes this.
  4. Pierre Boulanger

    Pierre Boulanger Active Member

    Thank you both. Regarding likes & shares i changed "Use Full Friendly URLs" & "Romanize Titles in URLs" thats why I lost them.. When I revert the setting from ACP and all back in place but urls are huge. Can i change this setting and preserve likes as well?
     
  5. Mike

    Mike XenForo Developer Staff Member

    No, because these are external services that use the exact URL value as the identifier.
     
    Pierre Boulanger likes this.
  6. Pierre Boulanger

    Pierre Boulanger Active Member

    I know about that.. What i mean is that when someone was searching for 2cv or historic Citroen a lot of various links from my forum was availabe in google but now there is nothing even if i search using the exact node title!
     
  7. Adam Howard

    Adam Howard Well-Known Member

    Again, that is because you changed forum software. And so your links have changed and thus you're going to take a SEO hit. That hit varies for everyone. It can be as small as being pushed a few steps back or starting over.

    I know... Our site started with phpBB, phpBB with WordPress, vBulletin, vBulletn Suite, XenForo, SMF, IPB, and back to XenForo. Out of all those, we took the largest hit when we moved to IPB and basically our SEO started all over.

    Because you're not using a common top level domain name.... That hit maybe larger.
     
    Pierre Boulanger likes this.
  8. Pierre Boulanger

    Pierre Boulanger Active Member

    Thanks a lot for your time. I guess I'll have to wait. :)
     
    Adam Howard likes this.

Share This Page