1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Google+ / Google +1 button issues

Discussion in 'Resolved Bug Reports' started by OperaManiac, Jul 9, 2011.

  1. OperaManiac

    OperaManiac Well-Known Member

    I just discovered this problem. I believe it started occuring after I updated the forum to the latest stable edition.

    Here is what is happening.

    I believe Google spiders can access the forum. I have checked through Webmaster Tools.

    But Google +1 button is not working.

    [​IMG]

    Not working even from Google search result pages.

    Also noticed that if I try to share a link through Google Plus, Google tells me that the URL is unreachable:

    [​IMG]

    But if I try to share a static HTML file, it is accessed just fine:

    [​IMG]

    What I have checked...

    reverted all modified templates.
    checked the htaccess file.
    disabled nice URLs. did not change the behavior.
    even tried renaming the htaccess file... no use.

    everything seems to be ok. but i am just failing to resolve this problem.

    ----

    Just noticed that sharing link of this forum too is not working on Google Plus:

    [​IMG]

    And clicking the Google +1 button is also not working below.
     
    Mahmoud Mystero likes this.
  2. dieketzer

    dieketzer Well-Known Member

    i noticed the same thing on ragteks board today. i had assumed it was something limited to myself, since there was already a +1 recorded on the page.
    i dont have a 103 of my own to test it on.

    same thing happens on this very page in fact.
     
  3. OperaManiac

    OperaManiac Well-Known Member

    I can only assume that Google +1 Button and Google+ are having some issues right now. Otherwise XenForo developers would have noticed it!
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    It's working for me so it seems to be a non-general issue.
     
  5. Floris

    Floris Guest

    Same on http://xenfans.com/ I can't seem to +1 since this morning.
    I thought it was routing, now I am wondering if it isn't something else.

    Google +1 is great! Their in private beta testing, it's possible they've updated their code?
     
  6. OperaManiac

    OperaManiac Well-Known Member

  7. Brogan

    Brogan XenForo Moderator Staff Member

    It seems once your Google profile is blocked, it's blocked everywhere.

    I just tried it on Floris' site and got the red button, now I get the red button here, and also on my own site.

    So it's definitely a Google issue.
     
  8. OperaManiac

    OperaManiac Well-Known Member

  9. Brogan

    Brogan XenForo Moderator Staff Member

    The code has been customised somewhat to stop loading time impacting the rest of the page.
    It would appear Google have updated their API and it's no longer working properly.

    Facebook are bad enough for doing this so if Google are going to go the same way then I'll just deactivate it on my site.
     
  10. OperaManiac

    OperaManiac Well-Known Member

    it does not work from the google search result pages. it does not work using a browser extension i use. and it also does not work when i add the button code manually (copied from the google site) in the template. this is not a problem with xenforo's integration of google +1 button.
     
  11. Brogan

    Brogan XenForo Moderator Staff Member

    So it is Google then.
     
  12. OperaManiac

    OperaManiac Well-Known Member

    here is what i am trying to say...

    something might have changed in the 1.0.3 edition. xenforo generated pages are not being read by google +1 button and google+ social network. static pages on the same domains (not generated by xenforo) are doing just fine!

    i would keep an eye on this thing and report back tomorrow if this resolves by itself. otherwise, i would request you to ask one of the developers to look into it! thanks. :)
     
  13. Floris

    Floris Guest

    Interesting.

    Upon release of 1.0.3, it worked though .. I've +1'd a few pages on release day, after upgrade to 1.0.3 on my site.
     
    OperaManiac likes this.
  14. OperaManiac

    OperaManiac Well-Known Member

    ah. if it worked for you after updating to 1.0.3, i cannot think of anything that could be the reason. i guess waiting is the only option right now! thanks.
     
  15. Brogan

    Brogan XenForo Moderator Staff Member

    Maybe I'm missing the point, but the Google +1 button didn't exist in XenForo before 1.0.3.

    And I have successfully used it on my site since upgrading to 1.0.3.

    Edit: What Floris said.
     
  16. OperaManiac

    OperaManiac Well-Known Member

    agreed. i now realize that it worked after 1.0.3 was released. so problem lies somewhere else.

    google +1 button existed before xenforo 1.0.3 was released. it existed on search result pages. i had added the code manually using the template editor. and of course there are browser extensions :)
     
  17. Gultog

    Gultog Member

    When i click the +1 button in my forum, it become like this, help me
    error.jpg
     
  18. Forsaken

    Forsaken Well-Known Member

    OperaManiac likes this.
  19. Gultog

    Gultog Member

    I know that, but i dont block my profile, my friend can't click it too. For the 3rd reason, how to enable Google Profiles?
     
  20. Trombones13

    Trombones13 Well-Known Member

    Other users are reporting this as well--see this thread. No resolution yet.
     

Share This Page