1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Google +1 Enable option not available

Discussion in 'Troubleshooting and Problems' started by Junior, Aug 23, 2011.

  1. Junior

    Junior Well-Known Member

    Going from ACP > Options > Search Engine Optimisation (SEO), I do not have an option to enable google +1. I've upgraded from either XenForo 1.0.0 or 1.0.1 to 1.0.4. It was a while ago that I upgraded so I do not remember exactly where I upgraded from.

    I used the upgrade only files when upgrading and today uploaded the full download to ensure no files missed updating. I still do not have the option to enable google +1.
     
  2. Cezz

    Cezz Well-Known Member

    Can you supply a screenshot of what you do see?
     
  3. Junior

    Junior Well-Known Member

  4. Russ

    Russ Well-Known Member

    Did you try running: admin.php?tools/file-check
     
  5. Junior

    Junior Well-Known Member

    I upgraded to 1.0.4 the day it came out and noticed I didn't have +1, was too focused on other things to fix it. I ran the file check that day and just now. I get the smiley face, we good on that. :)
     
  6. Cezz

    Cezz Well-Known Member

    in the share_page template do you see the following code?

    Code:
                <xen:if is="{$xenOptions.plusone}">
                    <div class="plusone shareControl">
                        <div class="g-plusone" data-size="medium" data-count="true" data-href="{$url}"></div>
                    </div>
                </xen:if>
     
  7. Junior

    Junior Well-Known Member

  8. Brogan

    Brogan XenForo Moderator Staff Member

    I've moved this from bug reports to troubleshooting until/if it's confirmed as a valid bug with 1.0.4.

    Can you enable debug mode and then see if you can navigate to this URL?

    install-path/admin.php?options/edit-option/plusone
     
  9. Junior

    Junior Well-Known Member

    Debug enabled

    Error
    The requested option could not be found.

    From my knowledge I'm assuming it had something to do with not updating in the proper order. There is nothing wrong with the files. I have reuploaded many times and the file check says all files are good. Templates have updated by my admin panel options have not.
     
  10. Brogan

    Brogan XenForo Moderator Staff Member

    There is no requirement to install interim upgrades, you can safely upgrade from 1.0.0 to 1.0.4 missing out all the other releases.

    I'm trying to think what would cause this, as it appears the front end templates have upgraded correctly.
     
  11. Cezz

    Cezz Well-Known Member

    Then it seems only the option is missing, but the core code is there... interesting... maybe you could just try manually creating the option (not sure if it is the cleverest idea though)
     
  12. Brogan

    Brogan XenForo Moderator Staff Member

    Kier suggested navigating to /install and running that again.

    Can you try that?
     
  13. Junior

    Junior Well-Known Member

    Went to the install path and clicked Rebuild Master Data and everything worked out. Could this have been a bug from not having the full package and upgrading from 1.0 with just the upgrade files of 1.0.4?

    Either way resolved.
     
  14. Brogan

    Brogan XenForo Moderator Staff Member

    No, as I posted above, you don't need to install every release and in fact many people miss out some of the maintenance releases.

    Difficult to say what could have caused it.
     
    Junior likes this.

Share This Page