XF 1.5 getaddrinfo failed: Name or service not known

twollert

Active member
Lately I get tons of these error messages:

Zend_Db_Adapter_Mysqli_Exception: php_network_getaddresses: getaddrinfo failed: Name or service not known - library/Zend/Db/Adapter/Mysqli.php:333
Generiert durch: Unbekanntes Benutzerkonto, Mittwoch um 11:47 Uhr

#0 /kunden/XXX/library/Zend/Db/Adapter/Abstract.php(315): Zend_Db_Adapter_Mysqli->_connect()
#1 /kunden/XXX/library/XenForo/Application.php(730): Zend_Db_Adapter_Abstract->getConnection()
#2 [internal function]: XenForo_Application->loadDb(Object(Zend_Config))
#3 /kunden/XXX/library/XenForo/Application.php(973): call_user_func_array(Array, Array)
#4 /kunden/XXX/library/XenForo/Application.php(1004): XenForo_Application->lazyLoad('db', NULL)
#5 /kunden/XXX/library/XenForo/Application.php(1609): XenForo_Application::get('db')
#6 /kunden/XXX/library/XenForo/Model.php(161): XenForo_Application::getDb()
#7 /kunden/XXX/library/XenForo/Model/DataRegistry.php(138): XenForo_Model->_getDb()
#8 /kunden/XXX/library/XenForo/Model/DataRegistry.php(97): XenForo_Model_DataRegistry->_getMultiFromDb(Array)
#9 /kunden/XXX/library/XenForo/Dependencies/Abstract.php(147): XenForo_Model_DataRegistry->getMulti(Array)
#10 /kundenXXX/library/XenForo/FrontController.php(127): XenForo_Dependencies_Abstract->preLoadData()
#11 /kunden/XXX/index.php(13): XenForo_FrontController->run()
#12 {main}

array(3) {
["url"] => string(56) "http://www.radioforen.de/index.php?members/XXX/"
["_GET"] => array(1) {
["members/XXX/"] => string(0) ""
}
["_POST"] => array(0) {
}
}
(XenForo 1.5.6)

What can I do to fix that?
 

Mike

XenForo developer
Staff member
This is saying that DNS can't resolve something. In this particular case, it's the host name of your MySQL server. You'll likely need to talk to your sysadmin.
 
Top