• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Full Friendly URLs Problem

#1

Mike

XenForo developer
Staff member
#2
First, ensure that you have the necessary .htaccess (or whatever setup is needed for your web server), in XenForo's directory.

If that's not the issue, then you likely need to edit your WP's .htaccess file to not match any community pages. Probably with something like this:

RewriteRule ^community - [NC,L]

Without seeing your WP htaccess, I'm not 100% sure where that should go, but it should be before the "final" RewriteRule.
 
#3
I've found that at times WP needs to be 'reminded' about how to format its permalinks. This is particularly true after upgrading plug-ins. Simply go to WP Admin and select Settings -> Permalinks and without changing anything, click the 'Save Settings' button.

Hope that helps. It's worked for me on several occasions albeit not with XF.
 
#4
First, ensure that you have the necessary .htaccess (or whatever setup is needed for your web server), in XenForo's directory.

If that's not the issue, then you likely need to edit your WP's .htaccess file to not match any community pages. Probably with something like this:

RewriteRule ^community - [NC,L]

Without seeing your WP htaccess, I'm not 100% sure where that should go, but it should be before the "final" RewriteRule.
This my WP htaccess:
Code:
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress
My XF htaccess:
Code:
#    Mod_security can interfere with uploading of content such as attachments. If you
#    cannot attach files, remove the "#" from the lines below.
#<IfModule mod_security.c>
#    SecFilterEngine Off
#    SecFilterScanPOST Off
#</IfModule>

ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 500 default

<IfModule mod_rewrite.c>
    RewriteEngine On

    #    If you are having problems with the rewrite rules, remove the "#" from the
    #    line that begins "RewriteBase" below. You will also have to change the path
    #    of the rewrite to reflect the path to your XenForo installation.
    #RewriteBase /community

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data|js|styles|install) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
</IfModule>
I've found that at times WP needs to be 'reminded' about how to format its permalinks. This is particularly true after upgrading plug-ins. Simply go to WP Admin and select Settings -> Permalinks and without changing anything, click the 'Save Settings' button.

Hope that helps. It's worked for me on several occasions albeit not with XF.
Try it and it did not work.
 
#8
I delete WP's htaccess and it did not solve the problem.

Edit:
I used a plugin to customize the htaccess. With following htaccess when I use Full Friendly URL I get 404 page that is not made by WP.
Code:
# BEGIN Wordpress

# WPhtc: Begin Custom htaccess
RewriteRule ^community - [NC,L]
# WPhtc: End Custom htaccess

# WPhtC: Protect WP-config.php
<files wp-config.php>
order allow,deny
deny from all
</files>

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END Wordpress
 

Mike

XenForo developer
Staff member
#9
Are you sure the .htacess file is actually in place for XF then? :)

If so, submit a support ticket and I'll look into it.