1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Friendly URL's not working

Discussion in 'Troubleshooting and Problems' started by Verringer, Apr 7, 2014.

  1. Verringer

    Verringer Active Member

    I know there's a million threads about this already- but I'm really struggling.

    I've re-installed the forum on several machines. I'm using Apache2, here's my .htaccess at the moment.
    #    Mod_security can interfere with uploading of content such as attachments. If you
    #    cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    #    SecFilterEngine Off
    #    SecFilterScanPOST Off
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
    <IfModule mod_rewrite.c>
        RewriteEngine On
        #    If you are having problems with the rewrite rules, remove the "#" from the
        #    line that begins "RewriteBase" below. You will also have to change the path
        #    of the rewrite to reflect the path to your XenForo installation.
        # RewriteBase /xenforo
        #    This line may be needed to enable WebDAV editing with PHP as a CGI.
        #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
        RewriteCond %{REQUEST_FILENAME} -f [OR]
        RewriteCond %{REQUEST_FILENAME} -l [OR]
        RewriteCond %{REQUEST_FILENAME} -d
        RewriteRule ^.*$ - [NC,L]
        RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
        RewriteRule ^.*$ index.php [NC,L]
    I did the mod_rewrite thing in httpd.conf

    <Directory "/var/www/cgi-bin">
        AllowOverride None
        Options None
        Order allow,deny
        Allow from all
    Could anyone help me with where I may have gone wrong? I just get 404'd on every URL except the homepage. Thankss
  2. Liam W

    Liam W Well-Known Member

    AllowOverride should be 'All' not 'None', and that httpd.conf tag is pointing to the wrong folder anyway...

    Verringer likes this.
  3. Verringer

    Verringer Active Member

    Thanks, I corrected it and it was still not working..

    I didn't realize there were several AllowOverrides.. My bad! :mad:

    I've spent 5 months trying to get this to work! Thanks:)

Share This Page