1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Forum shows 0 guests all the time

Discussion in 'Troubleshooting and Problems' started by redwolf6, Oct 12, 2013.

  1. redwolf6

    redwolf6 Member


    I just shared a post on facebook, goo.gl says 300 people clicked on the link. But my forum is always showing 0 guests. I even tried another laptop to see if it works and it's 0 guests all the time.

    How to fix this problem? I fear there's a problem with the online status on my forum.

    Thank you!
  2. Jeremy

    Jeremy XenForo Moderator Staff Member

    Is the total count changing? Have you tried disabling add ons?
  3. redwolf6

    redwolf6 Member

    Yes it's changing from time to time but all the guests and registered members have the same IP address which is weird.
  4. Jeremy

    Jeremy XenForo Moderator Staff Member

    Is your forum behind a proxy such as Cloudflare?
  5. redwolf6

    redwolf6 Member

    No, but I'm using cloud hosting from tsohost.
  6. Mike

    Mike XenForo Developer Staff Member

    If all the IPs are the same, there's definitely a "reverse proxy" in there. There are ways to workaround it, though it's usually preferable for the host to workaround it at that level (as it affects web server logs and all applications, for example). I would recommend contacting them. At the least, if they won't deal with it at the web server level (with something like mod_rpaf), they should be able to tell you the HTTP header that contains the original IP.
  7. redwolf6

    redwolf6 Member

    So here's a brief of this issue:

    All registered members and guests have the same IP = the IP of the server. So my hosting referred me to this tutorial (post 7):


    I tried that and now all guests and members have this IP:

    We tried this too:

    if (isset($_SERVER['HTTP_X_FORWARDED_FOR']))
    With no success!

    Appreciate any help and my hosting is helping me to sort this issue too!

  8. Mike

    Mike XenForo Developer Staff Member

    That is a common fix. Have you confirmed that the original IP (only) is in that header/$_SERVER variable?

Share This Page