1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. This forum has been archived. New threads and replies may not be made. All add-ons/resources that are active should be migrated to the Resource Manager. See this thread for more information.

First Post on All Pages

Discussion in 'Add-on Releases [Archive]' started by mizter1nho, Oct 19, 2010.

  1. mizter1nho

    mizter1nho Well-Known Member

    First Post on All Pages 1.1 for XenForo 1.1​
    This hack set show first post of thread on all pages.​
    For install/update read Install.txt​
    P.S Sorry for bad english​
    P.S.S Its my first add-on for XF.​

    Attached Files:

    Navid2zp, maryflower, mono and 23 others like this.
  2. maidos

    maidos Active Member

    can you set first post on default? also allow which forum sections to be automatically set on first post as default
  3. Adder

    Adder Active Member

    Thanks. Great hack for great forum engine :)
    Now testing...))
  4. mizter1nho

    mizter1nho Well-Known Member

    For this, execute query for DB with XF:
    UPDATE xf_thread SET firstpoststicked = 1
  5. Shelley

    Shelley Well-Known Member

    Could we get some screenshots? If I'm reading correctly this is similar to the "Chief Post" for vbulletin? And thanks for posting:)

    edit: In the chief post for vbulletin we had the option of 3-4 different layouts to choose from which is why I asked for a screenshot. I'm assuming the first post on all pages are the same as the standard post in that case no need for a screenshot.

    My suggestion is though if this is the case then an option in the admincp of alternative layouts (postbit) that distinguish from the standard postbit look. :)
    D37 and EntropiaPlanets like this.
  6. mizter1nho

    mizter1nho Well-Known Member

    This hack not based and not similary with "Chief Post".
    This hack only sticky first post on all pages.
  7. Vincent

    Vincent Well-Known Member

    <3 this modification :D
  8. mizter1nho

    mizter1nho Well-Known Member

    Fixed bug with attachments.
    For fix, download attachment and re-upload files only.
  9. mizter1nho

    mizter1nho Well-Known Member

    Released Beta 2.
    Fixed 2 bugs (when creating threads + showing first post, and now everything works fine)
    For update see Install.txt
    Addon in the first message.

    P.S. Due to no knowledge of API crept a lot of errors, like going to fix it:)
  10. SchmitzIT

    SchmitzIT Well-Known Member

    Awesome work :) I love this feature, and while users on my forums initially were confused by it, it now seems to have grown on most of them. If there will be an ability to differentiate the template for the first post so it stands out, that would truly be fantastic.

    But thank you :)
  11. Rob

    Rob Well-Known Member

    Love this mod, but as has been said already it needs two options. firstly, a setting in forum options to turn this on and off per forum as a default. I suggest the edit options per thread inherit from this and user can of course over-ride the behaviour inherited from the forum.

    Secondly, I think users really do need to be able to distinguish this from other normal (non sticky) posts so the abillity to use an alternative post bit template will be extremely useful

    Nice mod :)
    Digital Doctor, Shelley and ArnyVee like this.
  12. ArnyVee

    ArnyVee Well-Known Member

    Good idea and necessary :)

    Absolutely necessary. :D
  13. Vincent

    Vincent Well-Known Member

    When trying to uninstall:
  14. mizter1nho

    mizter1nho Well-Known Member

    Package updated.
  15. yavuz

    yavuz Well-Known Member

    does it now work with the latest xenforo (beta5) ?
  16. Vincent

    Vincent Well-Known Member

    I still get that error :S
  17. mizter1nho

    mizter1nho Well-Known Member

    Re-upload files, i not have errors.
  18. Goodspeed

    Goodspeed Member

    Is it working with xenforo 1.0.4?
  19. x7iBiT

    x7iBiT Member

    I just try it and doesn't work :(
  20. cografik

    cografik Member

    Online Status 1.1
    seems everyone is offline
    conflicts with two plug-in

    but I'm online
    FirstPostOnAllPages>>closed the it over the hump

Share This Page