1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

File health Check: File does not contain expected contents

Discussion in 'Troubleshooting and Problems' started by gldtn, Nov 27, 2011.

  1. gldtn

    gldtn Well-Known Member

    I'm getting this problem while checking file health:

    File does not contain expected contents.
    Is anyone else getting this? I tried re-uploading the file, but it still remains.. should I be worried since it's a permission file?

  2. James

    James Well-Known Member

    Did you re-upload from your local version or did you re-download the file and upload it? If the former, re-download the zip file and upload that file again.
  3. gldtn

    gldtn Well-Known Member

    James, at first I tried from the local, than I re-downloaded and tried again and I still have the same error. The file says 72kb, both local and on the server. I opened it up and it seems complete..

    Any ideas?
  4. Brogan

    Brogan XenForo Moderator Staff Member

    The hash file could possibly be the problem I suppose.

    I would suggest downloading the .zip once more and uploading all files again.

    Which FTP program do you use?
  5. gldtn

    gldtn Well-Known Member

    Nothing like the good ol' Filezilla ftp to the rescue. I just uploaded the file with filezilla and it worked :D

    Both with Transmit & Forklift was giving the same problem. Wonder why most of these paid FTP clients do this.. ?

    Thanks guys!
  6. RobParker

    RobParker Well-Known Member

    Yep, I had the same problem with Permission.php and exactly the same solution (Transmit and Cyberduck didn't solve it but FileZilla did).
  7. DSF

    DSF Well-Known Member

    With filezilla it's ok.
    Many other ftp-progs change the unvisible EOF-Mark of scripts and therefore you get a error message resp. a other hash.
  8. RobParker

    RobParker Well-Known Member

    Strange that they only do it to Permission.php though isn't it?
  9. cmeinck

    cmeinck Well-Known Member

    Weird. Same issue using Transmit for Mac. Filezilla resolved the problem.

Share This Page