1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[1.5.2] File does not contain expected contents

Discussion in 'Troubleshooting and Problems' started by Robru, Oct 20, 2015.

  1. Robru

    Robru Active Member

  2. Robru

    Robru Active Member

    I have fully upgraded to 1.5.2
     
  3. Brogan

    Brogan XenForo Moderator Staff Member

    Can you try downloading a new upgrade .zip and uploading the files again?

    I'm not able to replicate this on several installations which I have upgraded to 1.5.2.
     
  4. Robru

    Robru Active Member

    I do the upgrade again now, Brogan.
     
  5. Robru

    Robru Active Member

    Can I cleanup the File Health Check log before I do a new upgrade?
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    There is no log for the file health check, other than the admin log which just records the action.
     
    Robru likes this.
  7. Robru

    Robru Active Member

    After the second try of the upgrade, I have the same issue and a slower loading site ...
     
  8. Chris D

    Chris D XenForo Developer Staff Member

    The file health check appears to be correct.

    The xenforo.js file on your server appears to be from XenForo 1.5.1.
     
  9. Robru

    Robru Active Member

    I try the patch again.
     
  10. Chris D

    Chris D XenForo Developer Staff Member

    You probably only need to re-upload those two files; js/xenforo/xenforo.js and js/xenforo/full/xenforo.js.

    Take extra care by viewing your FTP transfer log to make sure there are no errors when those files are uploaded.

    In the few times I've seen something similar, it has helped to physically delete the file from the server before re-uploading.
     
  11. Robru

    Robru Active Member

    I did delete both files first ;)

    /js/XenForo
    upload_2015-10-21_1-13-18.png

    /js/XenForo/full
    upload_2015-10-21_1-15-51.png
     
  12. Chris D

    Chris D XenForo Developer Staff Member

  13. Robru

    Robru Active Member

    Yes!
     
  14. Chris D

    Chris D XenForo Developer Staff Member

    That's the problem...

    You need to do ONE of them.

    You either apply the patch (attached to that thread) to XF 1.5.0 or XF 1.5.1 OR you download and install the 1.5.2 package from your customer area. XF 1.5.2 contains the patch files already.
     
  15. Robru

    Robru Active Member

    So, I must download the upgrade package now, and renew only the two files on my server?
     
  16. Chris D

    Chris D XenForo Developer Staff Member

    Yes, that should do it.
     
  17. Robru

    Robru Active Member

    Thank you, they are no longer mentioned in the file health check ;)
     

Share This Page