1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Crons not running and File Health Check error

Discussion in 'Troubleshooting and Problems' started by veemon, Feb 27, 2016.

  1. veemon

    veemon Member

    Hey there~

    We lost all our files a few days ago when we were attacked by some hacker.
    I managed to restore everything from the day before with the help of the daily cpanel backups.

    But ever since the restore, the cronjobs started not updating themselves.
    If I run them manually and deactivate/ reactive them, they get updated but will fail to update again on the next run. There are also no errors in the server_error_log that show any problem with a specific cron.

    I've been looking around for a while and tried to run a file health check but it just threw me an error, as seen in my attachment. And before the attack everything worked well... No changes were made afterwards.

    I thought that the problem might be with permissions but they were all correctly set to either 7/5/5 or 6/4/4.

    I'm seriously stumped on this so it would be nice if anyone could help me here q.q

    Thanks in advance!
     

    Attached Files:

  2. Mike

    Mike XenForo Developer Staff Member

    The error you're getting with the file health check is why crons aren't running: the runner isn't available. It's deferred.php in the root of your XF directory. If that's showing as the correct permissions to you, you'll need to contact your host to ask why it's not accessible.
     
    veemon likes this.
  3. veemon

    veemon Member

    Thanks!
    Turns out that the deferred.php somehow wasn't restored correctly.
    I just replaced it with a backup I had on my local computer and that fixed the issue for now! :)
     

Share This Page