1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Facebook integration error - OAuthException please help

Discussion in 'Installation, Upgrade, and Import Support' started by Stuart Wright, Oct 14, 2010.

  1. Stuart Wright

    Stuart Wright Well-Known Member

    { "error": { "type": "OAuthException", "message": "Invalid redirect_uri: Given URL is not allowed by the Application configuration." } }

    Site URL is http://www.thejoyofatheism.co.uk/forums/
    The Site Domain is thejoyofatheism.co.uk
    both correct. What am I doing wrong?
     
  2. JVCode

    JVCode Well-Known Member

    My site works with facebook integration, I have the following filled out;
    Site URL; http://mumsdiscussion.com/
    Site Domain; mumsdiscussion.com
    Canvas URL; http://mumsdiscussion.com/
    Canvas FBML/iframe; iframe
    Deauthorize URL; http://mumsdiscussion.com/

    And ofcourse you'll need to have the facebook page in your admincp on xenforo filled out. Once the application settings have been submitted, it can take upto 15-30 minutes before it takes effect on facebook servers.
     
  3. JVCode

    JVCode Well-Known Member

    Nice, you have Kier registered on your site (or have you ;)) I think he should join my site, "MumsDiscussion" lmao :D
     
  4. Stuart Wright

    Stuart Wright Well-Known Member

    Entered the canvas URL as well. Still getting the same error. :(
     
  5. Stuart Wright

    Stuart Wright Well-Known Member

    Can anyone help with this, please?
     
  6. erich37

    erich37 Well-Known Member

  7. Stuart Wright

    Stuart Wright Well-Known Member

    I followed the instructions exactly and still get
    {
    "error": {
    "type": "OAuthException",
    "message": "Invalid redirect_uri: Given URL is not allowed by the Application configuration."
    }
    }
     
  8. Stuart Wright

    Stuart Wright Well-Known Member

Share This Page