• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 Xenforo's social integration error

#1
So I am trying to get Facebook Integration to work on my website. I made a Facebook app and it went live with the proper setup:

2015-07-17 14_39_45-MCME Login.png

I setup my Xenforo installation with the application id and the secret key. Now whenever a user (does not matter if registered or trying to associate and already excisting account) tries the Facebook Integration, it prints the following error:

Minecraft Middle Earth - Error
Facebook did not provide an email address for your account. Please ensure that you have a confirmed email address listed in Facebook and try again.
I also tried associating my own account on the website (where I used the Facebook Integration both here on Xenforo and on numerous other websites, and it works.) So the error where it says that I don't have a confirmed email doesn't make any sense. I think the error lies somewhere with my forums not getting the email adress.

Anyone has any experiences with this?
 
#4
I am also trying the Google Integration, but I have issues with that one as well. Is this related to the same bug?

400. That’s an error.

Error: origin_mismatch

Application: Minecraft Middle Earth

You can email the developer of this application at: webmaster@mcmiddleearth.com

Request Details
That’s all we know.
 

Brogan

XenForo moderator
Staff member
#5
The Google error is typically due to incorrect settings (URL) in the app.

Ensure you have set all of the fields up correctly.
 
#6
The Google error is typically due to incorrect settings (URL) in the app.

Ensure you have set all of the fields up correctly.
There are only two fields right? I created a new project at the Google Developer Console, went to APIs and Auth > Credentials. I then had to setup a consent page which I did with all the fields filled in.
After that, I could Create Client ID for a web application where I just put my domain twice inside "Authorized JavaScript origins" and "Authorized Redirect URI's" right? I think that's the only place where things can go wrong.

edit: Managed to fix the issue by adding a Domain Name Registration and Web Hosting | Domain.com and a Domain Name Registration and Web Hosting | Domain.com entry.
 
Last edited: