• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Facebook integration - doesn't match help file

#1
Ok reading this:
http://xenforo.com/help/facebook/

Step by step
1. Browse to https://developers.facebook.com/ and be sure that you're logged into your Facebook account. Note that you must be logged in as a person, not a page.

2. Click the Apps tab at the top and then click on the + Create New App button.
OK done easy

3. Give the application a name, for example your site or domain name, Agree to the terms and conditions and click on the Continue button.
Not quite. But close.
Asks for
Display Name
Namespace
Category (from a drop down)

By proceeding you agree to the terms and conditions. OK so doesn't match up with the help file but done....

4. Configure the basic settings on the next screen, including your Content Email andApp Domains. You will also want to disable Sandbox Mode. In the domains box, do not include anything other than the domain name.
Nope, nothing like that. I now have a screen that is titled Dashboard and gives me an appid and a secret.

Down the left is a series of submenus
Settings
Status & Review
App Details
Roles
Open Graph
Alerts
Localize
Payments
Insights

So I figure maybe it is in settings.

I get a screen that returns the Display Name and Namespace I entered to get here and is asking me for
App Domains
Contact Email

I change the contact email from personal to the work one and anything I put in App Domains generates an error:
"This must be derived from Canvas URL, Secure Canvas URL, Site URL, Mobile Site URL, Page Tab URL or Secure Page Tab URL"

What are they and how do they relate?

There is nothing to do with sandbox

There is also a big button that has +Add Platform on it and if I click that I get to select an operating system!!

5. From the list of integration options at the bottom, select Website with Facebook Login and enter your URL. This should just be the domain that you installed XenForo to, including the http, the www part (if necessary), and a trailing slash. For example, http://www.xenforo.com/ or http://xenforo.com/.
In the footer there is
Products
Facebook Login
Opengraph
Parse
and some more

If I follow the Facebook login page link it is just a link, not a selection and it takes me off to an information page about that.
https://developers.facebook.com/products/login/

6. Click on Save Changes to update your app.Finally, make a note of the Application ID and App Secret which are listed on the main page; this is the data you must enter in to your XenForo control panel.
Well I can't get past part 5 here so I never see anything like this.

None of the other left hand menu options remotely resemble this help file either
Status & Review
App Details
Roles
Open Graph
Alerts
Localize
Payments
Insights

Where am I going wrong??
 

Brogan

XenForo moderator
Staff member
#2
Facebook constantly change how they do things so keeping documentation up to date is an ongoing task.

I haven't gone through the process of setting an app up for a few years so I am not sure what the exact steps are now.

Ultimately all you need to do is create the app and get the App ID and App Secret which you then enter in the ACP.
 

ftsservice

Active member
#3
No, the App ID and App Secret are not enough.

I get the same error message in Facebook:
"This must be derived from Canvas URL, Secure Canvas URL, Site URL, Mobile Site URL, Page Tab URL or Secure Page Tab URL"

And even though FB has an App ID and secret they do not work at that point. Testing integration gives the following error message:

"Given URL is not allowed by the Application configuration.: One or more of the given URLs is not allowed by the App's settings. It must match the Website URL or Canvas URL, or the domain must be a subdomain of one of the App's domains."

I can't for the life of me figure it out. Can someone please give directions/instructions which work with the current Facebook book app setup, because right now the instructions are completely useless to me. :(
 
#4
Same error I get, gave up before Christmas to "try again with fresh eyes" in the new year. Was on my list to look at in the next week or so so pleased it isn't just me!
 

Mike

XenForo developer
Staff member
#5
You need to set the website URL. On the app settings, you need to enable the "Website" platform and set the necessary URL there. (If it's not appearing, click "Add Platform".)