1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Error MEssage When Adding Super admin

Discussion in 'Troubleshooting and Problems' started by P0ny, Jul 29, 2014.

  1. P0ny

    P0ny Member

    Have just tried to add an existing admin as a Super Admin via the config file as per instruction but keep getting this error:
    Parse error: syntax error, unexpected ',' in /homepages/****/********/htdocs/*******/discussion2/library/config.php on line 10
    I've checked and double checked for any extra commas and there aren't any. Advice please.
  2. Brogan

    Brogan XenForo Moderator Staff Member

    It should appear like this:
    $config['superAdmins'] = '1,2';
    The error is related to a problem on line 10.
  3. P0ny

    P0ny Member

    Blimey, that was quick :) This is a direct copy from from my config file. Line 10 corresponds to the line affected.
    $config['db']['host'] = 'db*****.db.1and1.com';
    $config['db']['port'] = '3306';
    $config['db']['username'] = '******';
    $config['db']['password'] = '*****';
    $config['db']['dbname'] = '*****';
    $config['superAdmins'] =‘1,1135’;
  4. Mike

    Mike XenForo Developer Staff Member

    You added smart quotes. It needs to be ' like the lines above.
  5. P0ny

    P0ny Member

    Thanks for quick response. Hmmm. Strange, all I did was add the 1135 within the quote marks that were already there, must an issue with text editor used. I'll have another go with a different editor.
  6. Chris D

    Chris D XenForo Developer Staff Member

    I recommend Notepad++ on Windows and TextWrangler on Mac OS X.

    Both are geared very much towards editing many different code languages and whenever I have used either I have never experienced any issues with incorrect characters.
  7. P0ny

    P0ny Member

    That did the trick, Mike, many thanks. I originally edited the config via Filezilla and not sure which editor it used. By default, php files are edited on my mac with 'Text Wrangler' which I used this time and it worked.

    Thanks again.
    Chris D likes this.
  8. P0ny

    P0ny Member

    Thanks Chris. I just edited with Text Wrangler it worked fine this time. Must look at setting it as the default editor within Filezilla.
    Chris D likes this.
  9. Chris D

    Chris D XenForo Developer Staff Member

    Yes, TextWrangler. That's the one I use, not TextMate.
  10. P0ny

    P0ny Member

    Thanks for all your input guys, much appreciated :)

Share This Page