XF 1.5 Error application.php

Betclever

Active member
Hi all,

Since I upgraded to PHP 7.1, I get an error message when I try to visit some external pages but the error comes from a php script of Xenforo:

Notice: A non well formed numeric value encountered in /home/.../public_html/library/XenForo/Application.php on line 1550
1510417479530.png

Do I have to modify this line to solve this issue cause all of my links point to this line 1550...?

Thanks for your help
 

Betclever

Active member
Thanks, I just found this thread lol but I don't have the same exact code so that's why I'm asking help cause I can't follow the above procedure...
 

Mike

XenForo developer
Staff member
For newer PHP versions, you need to make sure you're running the most recent version of XF1, currently 1.5.15. Older versions can have issues with changes from more recent versions of PHP.
 

Betclever

Active member
For newer PHP versions, you need to make sure you're running the most recent version of XF1, currently 1.5.15. Older versions can have issues with changes from more recent versions of PHP.
Yes I understand but Dohtheme made a custom style for me so I'm scared to upgrade even I use a child theme...
That's why I'm looking for a workaround to avoid any styling issue if I upgrade.
 

Chris D

XenForo developer
Staff member
To be frank, if you're concerned about it, then we can only recommend going back to PHP 7.0.

Don't let your choice of style constrain you from receiving potentially important updates (from XF or PHP).
 
Top