• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Class 'XenForo_Error' not found in /var/www/dev-netrider/library/XenForo/Application.php

Mouth

Well-known member
#1
Im copying a bunch (~20) of add-on uploads/... to my dev server )as part of testing for 1.1 upgrade to 1.2) and get the following error as soon as I do so....

Fatal error: Class 'XenForo_Error' not found in /var/www/dev-netrider/library/XenForo/Application.php on line 362

Fatal error: Class 'XenForo_Error' not found in /var/www/dev-netrider/library/XenForo/Application.php on line 384

Both line 362 and 384 are trying to ...

Code:
XenForo_Error::logException
Anyway of tracking down, which add-on it could be?
 

Mouth

Well-known member
#2
Activating $config['enableListeners'] = 0; in config.php means the homepage is blank (no error, as per above) and admin CP is blank too
 

Chris D

XenForo developer
Staff member
#5
If you have a decent editor, you should download your library folder to your PC (excluding Zend and XenForo directories as the error is unlikely to be contained in those) and do a find in path and search for XenForo_Error.
 

Mouth

Well-known member
#6
If you have a decent editor, you should download your library folder to your PC (excluding Zend and XenForo directories as the error is unlikely to be contained in those) and do a find in path and search for XenForo_Error.
Thanks, "library# grep -ir XenForo_Error *" identified 5 add-ons. Without having access to the admin CP to uninstall them, can I action their removal - 1 by 1 - to resolve and identify? Is it as easy as renaming or removing the directory within library/
 

Mouth

Well-known member
#9
Can you verify this file actually exists?
Thanks. Yes, exists ...
Code:
[...]
-rw-r--r--  1 root www-data  1910 Oct 10 16:54 DnsBl.php
drwxr-xr-x  2 root www-data  4096 Oct 10 16:54 EditHistoryHandler
-rw-r--r--  1 root www-data  7342 Oct 10 16:54 Error.php
-rw-r--r--  1 root www-data  1479 Oct 10 16:54 Exception.php
-rw-r--r--  1 root www-data  813 Oct 30 07:38 Facebook.php
[...]
Tried "library/XenForo/Install/run-upgrade.php" again, but this didn't resolve.

Silly me didn't take a file copy between 1.2 upgrade and copying over add-ons either :(
Guess the only option is to restore back to 1.1
 

Mouth

Well-known member
#11
Grab me on skype (peter.schmitzit) and let's see if we can work around this :)
Thanks, much appreciate the offer. Although I have already gone back to 1.1 and did the 1.2 upgrade again, and then applied each add-on one by one and found the issue.

QapTcha @ http://xenforo.com/community/threads/xf-qaptcha.41043/page-6#post-621439 was the issue, with a file permissions issue the same as experienced by http://xenforo.com/community/threads/xf-qaptcha.41043/page-7#post-639512