1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Fatal error: Class 'XenForo_Helper_Ip' not found in /path/to/library/XenForo/Sessio

Discussion in 'Installation, Upgrade, and Import Support' started by TheBigK, Mar 13, 2014.

  1. TheBigK

    TheBigK Well-Known Member

    Performing an upgrade from 1.2.5 to 1.3. Follow this process:-

    1. Turned board off
    2. Disabled all addons
    3. Started FTP (FileZilla) and started overwriting files
    4. Refreshed the browser page on www.crazyengineers.com
    5. Got following 'fatal error' :-

    Fatal error: Class 'XenForo_Helper_Ip' not found in /path/to/library/XenForo/Session.php on line 406

    File uploading is still in progress but have never encounterd any errors in all of previous upgrades that I performed. What's going on?
     
  2. BamaStangGuy

    BamaStangGuy Well-Known Member

    You haven't uploaded all the files :confused:
     
  3. TheBigK

    TheBigK Well-Known Member

    Correct, it's still in progress. However, XenForo typically shows message 'The board is being upgraded'; which looks good. Got an error for the first time and wanted to know if I really messed up anything.

    Will report as soon as file uploading is done.
     
  4. TheBigK

    TheBigK Well-Known Member

    Update:

    Alrighty, the upgrade was successful. After I uploaded all the files, the installer suggested that I should use Command Line installer. I had not tried it before but decided to give it a go (maybe I just put too much of faith in KAM). The installer worked like butter and the site's now back.
     
  5. RoldanLT

    RoldanLT Well-Known Member

    A small suggestion:
    Do not upload the files one by one.
    The best is zip the contents of upload folder then upload the archive then extract it on the server, that way you have a very less downtime, and you will not notice any error (y)
     
  6. TheBigK

    TheBigK Well-Known Member

    @RoldanLT - After uploading all the files; I just need to issue 'gunzip <name>' and the system will copy all the files; right? Is there anything I need to keep in mind?
     
  7. RoldanLT

    RoldanLT Well-Known Member

    > Download XenForo on Costumers Area
    > Extract on your Desktop
    > Navigate into the "Upload" folder
    > Zip/Archive all files
    > Upload the zip file to your xenforo Root Directory
    > On Ssh terminal run this command "unzip upload.zip"
    > press "A" to replace all files
    > Perform the upgrade either web or cli based.
     
    TheBigK likes this.

Share This Page