1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fatal error: Class '' not found in *snip*library/XenForo/Model/Node.php

Discussion in 'Installation, Upgrade, and Import Support' started by projectego, Oct 7, 2010.

  1. projectego

    projectego Active Member

    Hi folks,

    After just about managing to figure out how to fix the last problem - I seem to be encountering another.

    The import has apparently worked as it should. The initial went without a hitch, too, by the way. However, when now attempting to access the root index.php of my XenForo installation, I am greeted with this error message:

    Fatal error: Class '' not found in /home/ultimas/public_html/forums/library/XenForo/Model/Node.php on line 499

    I performed a search here and it seems I'm the only one encountering this problem. I'm re-re-uploading my XenForo files again just in case there was a problem the first two times *fingers crossed*, but after that, I'll be stumped. Any ideas, folks? All help would be most appreciated. Cheers!
  2. projectego

    projectego Active Member

    An odd development; when attempting to edit a certain forum from under the Node Tree page, I get this error:

    Warning: Unterminated comment starting line 42 in /home/*****/public_html/forums/library/Zend/Cache/Backend/File.php on line 42

    Parse error: syntax error, unexpected $end, expecting T_FUNCTION in /home/*****/public_html/forums/library/Zend/Cache/Backend/File.php on line 42

    This error only occurs for this forum and, my best guess is that this is the culprit which is causing the problem. Is there a safe way to remove threads from one forum to another from the admin CP? I really don't want to just delete the forum and lost all the threads contained in there.

    Edit: Nevermind. Disregard this post. I seem to be able to edit this category now, but the problem in my original post is still persisting. Oh, dear!

  3. Shamil

    Shamil Well-Known Member

    Upload all of the original files again, from a fresh download of XenForo.
    projectego likes this.
  4. projectego

    projectego Active Member

    Hi Shamill. Thank you for your response. I will try that again, but is it possible it might be something else causing the problem? My admin CP area appears to be working as intended but the actual forum, itself, produces the error. Is it possible that this is in some way a result of a botched import? I received no errors during the import, if that helps.

    I will re-attempt a re-upload of the files and let you know how I get on. This really is a strange one!
  5. Shamil

    Shamil Well-Known Member

    It's unlikely, simply becuase that error refers to a missing class, which is hard coded into the Zend Framework files.
    projectego likes this.
  6. projectego

    projectego Active Member

    Thank you for your help so far, Shamill. I'm afraid the error is still persisting. I'm very stumped at this point. I'm not sure if there's anything else that can be done, but I really don't fancy having to have to start from scratch again and re-import the contents of my vB database. Is there anything else you could suggest that I try?

    Just to clarify: I've re-uploaded several fresh copies of the XenForo software and the problem is just refusing to go away.
  7. Mike

    Mike XenForo Developer Staff Member

    It appears that you may have an incomplete node type cache, but I'm not sure why. There is code to allow it to be rebuilt, but it's not really trivial to trigger. There's a possibility that the data is missing in the underlying position as well, though it shouldn't be.

    Did you try to view the forum list at all before doing an import? If so, I assume that didn't trigger the error?

    Otherwise, I'd need access to troubleshoot it, as I don't know the state of your data. (And it's a pain that we don't know what in particular is triggering this.)
    projectego likes this.
  8. projectego

    projectego Active Member

    Mike, thank you for responding. I will PM you my login details. Thank you again Shamill for attempting to fix the issue.
  9. projectego

    projectego Active Member

    I'm not sure if this is of any relevance, but it seems I can access certain forum pages such as: http://forums.projectego.net/members/

    Just not the index.php. I thought I'd best share that in case it perhaps might help others diagnose the problem.
  10. Mike

    Mike XenForo Developer Staff Member

    It was an empty node type cache. Absolutely no idea why that'd happen though...
    projectego likes this.
  11. projectego

    projectego Active Member

    Crikey. Well, that is odd. I must thank you so promptly looking into this! Not 30 minutes after contacting Mike was my forum up and running again. Cheers, Mike!
  12. lazer

    lazer Well-Known Member

    Wow, now that's service. :)

    Glad to hear it all worked out for you.
    projectego likes this.
  13. projectego

    projectego Active Member

    Well, it seems as though the "Like" system is not working at present on my newly imported forum. When I click "Like", I get the little loading bar in the top right to show me that the forum has recognized the command, but the text doesn't change to "Unlike", nor does it count towards anyone's "Like" count. Any ideas, chaps?

    I really appreciate the help so far by the way!
  14. projectego

    projectego Active Member

    Also, apparently smilie text - ie: :) :D ;) - is not being converted to the graphic equivalent on my forum. Any word on how to fix this? I'd especially like to have the "Like" system in use on my forum, if there's any way to fix that then I'd be delighted.

    Edit: It appears only a select few users can change their avatar; most people seem to get an error mesage stating "A server error occurred. Please try again later."

    I also noticed that the import screwed up a few usergroups. I wasn't even assigned as an administrator after the import but my friend was. Very strange.
  15. projectego

    projectego Active Member

    I've found a method of fixing the avatar problem: deleting the entire avatar folder and its sub-folders located within the Data directory. This will allow users to upload new avatars but everybody is left with broken/missing avatar images until everybody uploads a new one. Not a great fix, but it's all I could come up with.

    It now appears my 'Report' functionality doesn't work either; I'm not sure if it ever did, but my users have confirmed that it is not working for them either.

    I would genuinely appreciate any help whatsoever. Cheers.
  16. projectego

    projectego Active Member

    I've attempted a fresh re-upload of all the files and I'm going to have a look at perhaps re-installing the software - hopefully without losing any threads, posts, members, etc. - but I really wouldn't refuse any help whatsoever, guys. The error logs in the admin CP provide me with nothing and my community is not best-pleased with many of the features not working. If any of the XenForo team could look into this, I would very much appreciate it. Cheers.
  17. projectego

    projectego Active Member

    No luck so far, chaps. I'm still encountering each and every one of the problems I've listed above. Am I too just wait until XenForo is officially released and out of the beta stage before I can request that a developer look into this again? It's a little disheartening to be left with features that are either glitchy or broken altogether. I look forward to any responses.
  18. Mike

    Mike XenForo Developer Staff Member

    I don't mean to pull out this card, but it's beta software for a reason. I really wouldn't recommend anyone run it in production. At the very least, there are issues that can only be fixed by a reimport. There are issues that will probably be fixed with beta 2, though it is theoretically possible that they're ingrained in the data now.

    Presumably it's not feasible due to loss of data, but if you're determined to run the beta in production, I'd probably recommend a fresh install and import with beta 2.

    At the very least, you should make separate threads for the issues you're having.
    projectego likes this.
  19. projectego

    projectego Active Member

    Mike, thank you for your response. I have performed an upgrade to the 1.0.0 Beta 2 and also updated my current template. I'm afraid that the problems are still occurring. With regards to a re-import: are they are problems with doing this, this late? Would I lost any new posts or data? I still happen to have my vBulletin database on my server so a re-import would not be a problem; I'm just wondering if there might be any consequences or performing a re-import. Would any new responses to threads that were not part of the vB forum be lost? Obviously, if this is the case, then it will be quite a large inconvenience for me and my community.

    Am I even able to perform a re-import at this point without losing data? Is it definitely necessary? Is it likely that it will fix the Like system, report system, server errors when attempting to upload new avatars, and other problems?

    I also thought it best to contain all of my bugs within a single thread, rather then create an additional new thread for each problem as I would assume they are all a result of the import. I have not witnessed any of the problems I have mentioned in this thread on any of my other XF installations. However, I will create individual threads for the glitches I encounter in future.

    Thank you for your help thus far.
  20. Mike

    Mike XenForo Developer Staff Member

    If you did a reimport, it would be of your vBulletin data. By definition, everything that occurred solely on XenForo would be lost.

    If you send me the contents of your error log, I can try to look into the issues. But I can't promise that they can be fixed retroactively.

Share This Page