1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Emoticons don't show up in emails...

Discussion in 'Resolved Bug Reports' started by Liam W, May 3, 2015.

  1. Liam W

    Liam W Well-Known Member

    May not be a bug, but just ignoring content isn't a good thing.

    When an email is sent out containing the text of the content is was sent out for, any emoticons are completely missed out.

    The emoticon or at least the replacement text should be included in the email.

    Liam
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    If you're using a sprite, that is to be expected.
     
  3. Liam W

    Liam W Well-Known Member

    Indeed, but just missing out content completely shouldn't. If it isn't going to be included, it shouldn't be replaced at all when sending the email.

    Context can be missed without the emoticon - they're quite important.
     
  4. Mike Creuzer

    Mike Creuzer Well-Known Member

    Arguably, your content should be independent of the need for emoticons. But Im just being argumentative for the sake of it :p <-- ;)
     
  5. Mike

    Mike XenForo Developer Staff Member

    We actually had full code to support this, but it seems that clients don't support it, likely because sprite smilies require a background image. In a quick Thunderbird test, I was actually getting the alt text to display which was ideal since it was the smilie replacement. However, Gmail actually displayed the clear image meaning nothing appeared to display (no background). (Thunderbird may have done that in other circumstances.)

    As such, I've disabled parsing them in HTML email now.
     
    Valhalla and Liam W like this.

Share This Page