Editor scrollbar glitch

Affected version
2.0.0 RC 2

Lukas W.

Formerly katsulynx
This is probably something that needs to be passed down to Froala, but I wanted to report it here first in case it might be XF css related.

As images (or videos as a series of images) speak more than words: Video

It's probably really hard to reproduce I guess. This time it's definitly not zoom related, that video is taken on my desktop machine with no zoom in all places. The editor itself is located inside a form, much like the 'about you' field in account details, but without the sidebar on the left, on a max width display. If you (temporarily) delete the sidebar there via the browser inspector and turn of the left-padding on .p-body-content, you should be able to reproduce it with the following content:

Code:
[IMG]https://i.imgur.com/CuOUfvN.jpg[/IMG]

[FONT=Courier New]Unser Leben lang haben sie uns erzählt, dass es hinter der Mauer nichts gibt, als die endlos arbeitenden Maschinen, und das ewige Ödland. Seit Hunderten von Jahren leben wir nun schon eingepfercht in Nova 07, und das Einzige was uns noch bleibt ist das Spiel, um aus unserer Realität zu fliehen.  ,,,,,,[/FONT]
 

Mike

XenForo developer
Staff member
This might be more of a browser quirk, as I believe the element height (vs the max-height) is actually just detected in the browser.
 

Lukas W.

Formerly katsulynx
Which browser was the video made in? Firefox?
Latest Chrome on Win10.

Can you reproduce the issue on the Froala demo
I'll try once I get back to my computer.

Edit: @Chris_D I tried for a while, but can't reproduce it. I think this is mostly the case because the editor on their demo page doesn't scroll but increases it's height indefinitely though.
 
Last edited:

Lukas W.

Formerly katsulynx
I've experimented around with a similar setup, but even entering height values with sub-pixel precision for the image doesn't yield any similar result unfortunately.

The used setup is:
HTML:
<p><img src="https://i.imgur.com/CuOUfvN.jpg" class="fr-fic fr-dib" style="height: 119.499996185302727px"></p>

<p style="font-family: 'Courier New';">a,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,</p>
The height value seems kind of random, but it's actually as precise as I had the passion to get it. Turning the last digit into an 8 will display a scroll bar on my screen, leaving it at 7 will not. However, commas still won't trigger the behavior.
 

Chris D

XenForo developer
Staff member
I've attempted to reproduce this and been unable to thus far.

Are you able to reproduce it here anymore? Relevant changes since you submitted this report are Chrome 63 being released and we're now running Froala 2.7.3 here.
 

Chris D

XenForo developer
Staff member
I want to accept that answer, and move on, but I do actually think I experienced this myself in my W10 VM. I'll leave this open a bit longer so we can have another look at reproducing it.

I vaguely recall something similar happening in the XF1 editor, though I can't recall if that was something we fixed, or just accepted as being a bit of a browser quirk.
 

Lukas W.

Formerly katsulynx
I've been able to reproduce this once again on the board here.
Here's a small video: https://my.mixtape.moe/irxmtr.mp4

I've triggered it while replying to a private conversation. Here's the BB code of the message seen in the video:
W

W
W
W

W
[IMG]https://i.imgur.com/8iQF6Ah.png[/IMG]

W
[IMG]https://i.imgur.com/PyyZYda.png[/IMG]

wwwwwwwwwwwwwwwwwwwwwwwwwwwwww
 

Lukas W.

Formerly katsulynx
I've now noticed a number of times, that this issue also seems to exist in the code editor, most frequently happening when I'm editing templates.
 

Chris D

XenForo developer
Staff member
@katsulynx I'm currently trying to repro this again on Chrome 66 with no success there. Is this still happening? I'm wondering if it has been resolved in a recent update? Can't repro it in the template editor or Froala at this point. I'm pretty sure I could at least repro it in Froala at one point.
 
Top