[EAE Add-ons] Roles

[EAE Add-ons] Roles 1.0.2

No permission to download

Lawrence

Well-known member
Lawrence submitted a new resource:

[EAE Add-ons] Roles - Displays what roles members perform on your site.

This add-on will allow you to display roles members have been assigned to your forum. The roles selected to be displayed are set in options.

Features
  • displays members with roles on it's own page.
  • can display roles on user profiles and tooltip (see screen shots)
  • can display roles in posts (above the message)
  • can display who the thread starter is when viewing a thread
  • supports custom user titles (displayed first) for members belonging to a usergroup that is...

Read more about this resource...
 
Last edited:

Frode789

Well-known member
Nice!

Would it be possible to add image badges to the roles? (so instead of the text showing for "Designer, Admin, Mod" etc, it would show images for those roles?
 

Faust

Well-known member
Just installed, and doesn't really work. When clicking on roles, doesn't appear the user
 

Lawrence

Well-known member
I installed it on my site, found in my signature with no issues. Did you select the user groups in the options? And it relies on the view members permission.

Are any roles displaying in posts (options), and on profiles (options)?

It's been downloaded six times so far, I'll wait to see if any one else reports any issues.
 

Lawrence

Well-known member
Those are unticked.



Yes I did

Is the link to the roles page under the Members tab there? And if so, what happens when you click it?

The View member lists permission is under the general permissions. Use analyse permissions to see what the result is.
 

Faust

Well-known member
Is the link to the roles page under the Members tab there? And if so, what happens when you click it?

The View member lists permission is under the general permissions. Use analyse permissions to see what the result is.

This is what I have:

Annotation 2020-05-23 151555.png

Annotation 2020-05-23 151621.png
 

Lawrence

Well-known member
There is, but doesn't show any members selected by me from usergroups.

Only thing I can think of is that this add-on works off of secondary user groups. This is because all members primary user group should always be user group 2 (registered), are your user groups set that way?
 

Faust

Well-known member
Only thing I can think of is that this add-on works off of secondary user groups. This is because all members primary user group should always be user group 2 (registered), are your user groups set that way?

For some reason I can’t add a user to secondary use group.
 

Faust

Well-known member
Only thing I can think of is that this add-on works off of secondary user groups. This is because all members primary user group should always be user group 2 (registered), are your user groups set that way?

Looks like all fixed, there is one thing which is weird, for some reason the custom user colour disappeared
 
Top