[EAE Add-ons] Post Subject

[EAE Add-ons] Post Subject 1.0.1

No permission to download

Lawrence

Well-known member
Lawrence submitted a new resource:

[EAE Add-ons] Post Subject - Allow members to state a subject for their posts, creating a table of contents.

Post Subject will allow your members to add a subject heading to their posts, if the option for the forum(s) is set to allow. If you do not allow a post subject in other forums, there is an option to display the thread's title in the subject container (for each post after the first). Post subjects and post titles (if enabled) appear directly above the message block.

Displaying the thread's title above each message can be useful in keeping members focused on the topic at hand, especially so...

Read more about this resource...
 

securedme

Active member
I tried this add-on and basically it works as expected.

But in mobile version, (width less than 480px) the subjects in some replies (most) don't show up.
 
Last edited:

Lawrence

Well-known member
But in mobile version, (width less than 480px) the subjects in some replies (most) don't show up.
This is by design to save space when viewing with a mobile device with a resolution less than 480px. You can lower that value here:
Appearance -> Styles -> The style you are using - Style properties -> [EAE] Post Subject -> Post subject responsive break point
 

Lawrence

Well-known member
It would be good if there's an option to only allow post starter to use Post Subject in the replies so the table of contents wouldn't be messed up by all irrelevant relies when the poster is trying to write a novel or instruction or open box product introduction, etc.

It's a good suggestion. I originally made it to work this way thinking that when it came to writing stories only the thread starter would be able to reply, but I can see a benefit to add in the option you are suggesting. I'll make note of it for the next release.
 

Banana99

Member
Hi, we installed and later removed this Addon.

We are now getting the "One or more add-ons currently have actions pending and may be in an inconsistent state. Because of this, some errors may be suppressed and unexpected behavior may occur. If this does not change shortly, please contact the add-on author for guidance." error message

]> SELECT addon_id
-> FROM xf_addon
-> WHERE is_processing = 1;
+-----------------------+
| addon_id |
+-----------------------+
| EAEAddons/PostSubject |
+-----------------------+
1 row in set (0.00 sec)


What is the fix please?
 

Lawrence

Well-known member
Did this warning come up after you uninstalled the add-on? I spent the morning trying to reproduce this and could not. Then I hit Uninstall once more and after it began un-installing the add-on I closed out my browser, waited a few moments and re-opened it and went back to the AdminCP, that warning you highlighted showed up. I went to the list of add-ons and beside Post Subject was a warning the an action had to be taken, so I selected Uninstall add-on again, and it worked.

Are there any errors in the error log? Is the Post Subject add-on still listed as installed?
 

Banana99

Member
It came up sometime after it was uninstalled. And no, it's not listed as installed in the add-ons page.

Where can I find the error log?
 

Lawrence

Well-known member
If there was an error in the server error log in the AdminCP, you would have see a notice of this when you logged into your AdminCP.

If you use the admin search function and search for eaepsj and also eae_psj are there any results (there should not be). Also if you have access to phpMyAdmin, can you check to see if eaepsj_subject has been removed from xf_post, and eaepsj_allow_subject is removed from xf_forum. I'm curious to see where this failed.

Does the add-on show up as installable (if you didn't delete the files)? If you deleted the files can you re-upload and see if you can install it again?

I doubt this is from the add-on itself, something happened that interfered with the uninstallation.
 

Banana99

Member
There are no entries in the server error log.

Where is this admin search function - I cannot easily find it

The add-on does not show up on the add-ons page at all.
 

Lawrence

Well-known member
Where is this admin search function - I cannot easily find it
The magnifying glass on the blue bar at the top right of the adminCP page.
The add-on does not show up on the add-ons page at all.
Have you deleted the files after you first uninstalled it? If you did not delete them, then it would not be listed as installable if the directory permissions were changed so that the User no longer has read permissions for src/addons/EAEAddons/PostSubject/.

If you did delete src/addons/EAEAddons/PostSubject/ can you re-upload the files.
 

Banana99

Member
OK, no results found for the two items that you asked me to search for.

There's no directory called EAEAddons

What would you like me to do, download and install again?
 

Banana99

Member

Stack trace​

#0 src/addons/Andy/SimilarThreads/Repository/SimilarThreads.php(505): XF\Error->logError('Please deselect...')
#1 src/addons/Andy/SimilarThreads/XF/Pub/Controller/Thread.php(60): Andy\SimilarThreads\Repository\SimilarThreads->getSimilarThreadsEnhanced(102, 135413, 'Frank Onyeka (D...')
#2 src/addons/EAEAddons/PostSubject/XF/Pub/Controller/Thread.php(11): Andy\SimilarThreads\XF\Pub\Controller\Thread->actionIndex(Object(XF\Mvc\ParameterBag))
#3 src/addons/XenConcept/NextPreviousThread/XF/Pub/Controller/Thread.php(20): EAEAddons\PostSubject\XF\Pub\Controller\Thread->actionIndex(Object(XF\Mvc\ParameterBag))
#4 src/XF/Mvc/Dispatcher.php(350): XenConcept\NextPreviousThread\XF\Pub\Controller\Thread->actionIndex(Object(XF\Mvc\ParameterBag))
#5 src/XF/Mvc/Dispatcher.php(257): XF\Mvc\Dispatcher->dispatchClass('XF:Thread', 'Index', Object(XF\Mvc\RouteMatch), Object(SV\WhoReplied\XF\Pub\Controller\Thread), NULL)
#6 src/XF/Mvc/Dispatcher.php(113): XF\Mvc\Dispatcher->dispatchFromMatch(Object(XF\Mvc\RouteMatch), Object(SV\WhoReplied\XF\Pub\Controller\Thread), NULL)
#7 src/XF/Mvc/Dispatcher.php(55): XF\Mvc\Dispatcher->dispatchLoop(Object(XF\Mvc\RouteMatch))
#8 src/XF/App.php(2337): XF\Mvc\Dispatcher->run()
#9 src/XF.php(488): XF\App->run()
#10 index.php(20): XF::runApp('XF\\Pub\\App')
#11 {main}
 

Lawrence

Well-known member
I'm glad to read that re-installing it removed the error. Uninstalling it should take no more than a minute. Another add-on may be causing the issue.

Post Subject does not utilize searching. All that it does is allow members to add a subject heading, so it would not cause those errors. Try disabling those add-ons that are listed in the error, one at a time.

Did the Post Subject add-on uninstall?
 
Top