• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Fixed Drag and Drop upload in Chrome

MattW

Well-known member
#1
Drag and Drop fails to upload in Chrome 27.0.1453.94 m on Windows 7 64bit

Below is a video showing what it's doing


I can only upload via drag and drop through the quick reply, and not in a New Thread or More Options reply.
 

Mike

XenForo developer
Staff member
#5
It is very quirky in Chrome 27.0.1453.110 for Mac OS X. It also doesn't work when creating or replying to a conversation.
This is covered elsewhere, but expected: you don't have permission to attach files to conversations.

But either way, this looks like the drag handlers won't trigger if you drag directly over the editor iframe first, without hitting the outside document.
 

MattW

Well-known member
#7
This is covered elsewhere, but expected: you don't have permission to attach files to conversations.

But either way, this looks like the drag handlers won't trigger if you drag directly over the editor iframe first, without hitting the outside document.
Yep, just tried it by hitting outside of the editor first, and it works.
 

Luke F

Well-known member
#8
This is covered elsewhere, but expected: you don't have permission to attach files to conversations.

But either way, this looks like the drag handlers won't trigger if you drag directly over the editor iframe first, without hitting the outside document.
Put the iframe behind an invisible element on document unfocus?