XF 1.4 Can't use Upload Button, Can Drag and Drop

I can't use the attach button, but I can drag files into the reply box and upload that way.

It was working, then I installed an add-on, noticed the next day it wasn't working, removed the add-on, and the problem persists. Ideas? I'm going crazy!

I installed Andy's "change the date of the post" add-on. I believe it's possible that's what broke this. https://xenforo.com/community/resources/change-date.2371/

This is from the console output from Chrome

XenForo.activate(#document)
xenforo.js?_v=b282e842:392 XenForo.SquareThumbs: e.fn.init(1)
xenforo.js?_v=b282e842:392 XenForo.SquareThumbs: e.fn.init(1)
attachment_editor.js?_v=b282e842:6 flash url: https://www.felinediabetes.com/FDMB/js/swfupload/Flash/swfupload.swf
attachment_editor.js?_v=b282e842:13 Attachments changed, total files: 0, images: 0
xenforo.js?_v=b282e842:209 XenForo.init() 110ms. jQuery 1.11.0/1.2.8-dev
xenforo.js?_v=b282e842:286 OverlayLoader for https://www.felinediabetes.com/FDMB/attachments/upload?_params=Array

Any ideas? I've been reading for hours

I have rebuilt the user permissions cache multiple times, I have used the persmissions analyzer.. The permissions are very clear that my super-user, and a brand new test user can view and attach files.

The error is the pop up that reads:

The following error occurred:​

You do not have permission to view this page or perform this action.
 
Last edited:
The only file that appears to have changed is permissions.xml. I assume obviously that's because I installed, and removed that add-on. I don't have a backup of that file, so I don't really know what it should look like, nor what display_order means, either. I can see in the database there are numbers associated with permissions, but I'm not sure where those numbers are generated.

Such as:
xf_permission_combination_user_group
xf_permission_combination
xf_permission

Any help is appreciated. Including telling me to just upgrade to v2. lol
 
Tried that again, no change. Toggled for all user groups, and allow all but unregistered to upload.
Rebuilding the user cache now .... Nope no change
 

Attachments

  • upload.jpg
    upload.jpg
    21.4 KB · Views: 4
Last edited:
Thinking it might be useful, I checked the perms and change dates on the three files in this directory, and they haven't changed dates and are 644
library/XenForo/AttachmentHandler

Post.php, ConversationMessage.php, Abstract.php

In fact, no files in the Xenforo directory have had a date change.
 
Top