1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Disabling Trophies

Discussion in 'Resolved Bug Reports' started by Zynektic, Jul 18, 2015.

Tags:
  1. Zynektic

    Zynektic Well-Known Member

    Afternoon,

    With the new option to disable trophies, I am going to redo all my board trophies and do not want them to trigger when adding them. If I disable them on the forum and then work on adding my trophies will they still trigger or am I fine to go about adding them and enabling the system again once done to trigger whoever has met the criteria?

    Also, if I remove all trophies it will reset everyone's trophy points back to 0 correct?

    Cheers
     
  2. Sheldon

    Sheldon Well-Known Member


    Interesting questions, and these I'd like to know myself. Haven't read anything really defining this... but looking.
     
  3. Zynektic

    Zynektic Well-Known Member

    I have had the trophy system disabled all day, added trophies and it just triggered 38 alerts after relogged when a user reported it.

    I have to say, it did not trigger until the [AD] Credits add-on triggered gaining crystals for trophies, at least those are the notifications I have, not trophy notifications so I am unsure which triggered it.
     
    Last edited: Jul 18, 2015
    Sheldon likes this.
  4. Jeremy

    Jeremy XenForo Moderator Staff Member

    Once disabled, the system shouldn't be sending alerts as the cron to update and add trophies is disabled.
     
    Sheldon likes this.
  5. Zynektic

    Zynektic Well-Known Member

    That is what I thought, the only alerts I have are for the [AD] Credits add-on which triggers an alert and awards currency when a trophy is awarded, but if the trophy system is disabled I am not sure why it did that. I'll poke it in that thread, cheers.
     
  6. Zynektic

    Zynektic Well-Known Member

    I have no clue about this stuff but I'll leave that reply as I still cannot see which triggered anything.
     
  7. Sheldon

    Sheldon Well-Known Member

    Either it's a bug with XenForo still awarding trophies (as suggested in the reply), or the credits add-on is overriding the disable function....
     
  8. Zynektic

    Zynektic Well-Known Member

    @Mike @Chris D - Are either of you able to shed any light on this? Thanks
     
  9. Sheldon

    Sheldon Well-Known Member

    I don't think there is much light to shed. If you had it off, and no "XenForo" alerts were sent, but instead alerts from the add-on were... that sort of has to narrow it down, right?

    I don't see any other way for it to be an issue on XenForo's side.
     
  10. Jeremy

    Jeremy XenForo Moderator Staff Member

    XenForo awards trophies via a Cron job. XenForo doesn't look for users when creating a trophy to award it to.
     
  11. Chris D

    Chris D XenForo Developer Staff Member

    XenForo does, however, issue trophies when a user logs in. So, there is a bug here.
     
    Jake B. and Jeremy like this.
  12. Jeremy

    Jeremy XenForo Moderator Staff Member

    I felt like I was forgetting something. That's what staring at non-xf code for almost 48 hours gets you! lol
     
    Amaury likes this.
  13. Jake B.

    Jake B. Well-Known Member

    Glad we've got that solved. Thanks Chris!
     
  14. Zynektic

    Zynektic Well-Known Member

    Thanks for the help!
     
  15. Chris D

    Chris D XenForo Developer Staff Member

    This is fixed for beta 3, thanks.
     
    Sheldon and Zynektic like this.

Share This Page