1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Disable Draft doesn't work

Discussion in 'Resolved Bug Reports' started by JVCode, Nov 19, 2013.

  1. JVCode

    JVCode Well-Known Member

    Trying to disable drafts, but it doesn't seem to work, after disabling and returning to forum to compose a new thread, drafts are still being saved.

  2. AndyB

    AndyB Well-Known Member

    Try using a Default style to exclude the possibility that is the issue.
    Marcus likes this.
  3. Chris D

    Chris D XenForo Developer Staff Member

    Disabling drafts will not clear the current drafts that might exist in your database.

    After disabling the drafts, run the following MySQL query:

    TRUNCATE xf_draft

    That will certainly remove the existing draft. But the thing is to see if the auto saving of drafts stops after you have done that.
  4. Mike

    Mike XenForo Developer Staff Member

    If it's just related to an existing draft being loaded, then Chris is correct. I am making tweaks to ensure that old drafts are removed in this situation (as right now they're not).

    However, if it's related to drafts actually being saved, then I can't reproduce this.
    JVCode likes this.
  5. JVCode

    JVCode Well-Known Member

    This is what happens, it's using an existing draft from before drafts were disabled.
  6. Chris D

    Chris D XenForo Developer Staff Member

    Then that is currently working as expected.
    Manual removal will work for now (the query in my last post)

Share This Page