• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

[dc] Smiley Manager 1.1.0

No permission to download
Smiley manager will help you manage your smilies by grouping them into categories.

htdesignz

Active member
#1
htdesignz submitted a new resource:

[dc] Smiley Manager (version 1.0.0) - Smiley manager will help you manage your smilies by grouping them into categories.

Smiley manager will help you manage your smilies by grouping them into categories.

Main Features:
  • Add smiley categories
  • Add a smiley drop-down at the bottom of the editor
  • Add Display order to smiley
Installation:
  • Download & Upzip
  • Upload all files and folders in upload folder to forum root
  • Import XML File
Instruction:
  • Your existing smilies are categorized by a special category named Uncategoriezed.
  • There are...
Read more about this resource...
 

DRE

Well-known member
#4
^^^First person I thought of when I saw this addon was Shelley lol.


Don't forget to uninstall The Happy Place before installing this or it will show two smilie tabs below the quick reply box!
 

Shelley

Well-known member
#5
^^^First person I thought of when I saw this addon was Shelley lol.


Don't forget to uninstall The Happy Place before installing this or it will show two smilie tabs below the quick reply box!
Good advice. I'll repeat what 8thos said if you have the HAPPYPLACE ADD-ON installed ensure you uninstall this before Installing the DC Smiley Manager.

Excellent work on this HTDesignz on developing this and embracing all the suggestions made and even more so fixing the issues that occurred. I cannot thankyou enough and appreciated the time and effort you put into this and making it available to us all. (y)

Very happy with this, works absolutely great and enjoying the frontend category switcher to switch between smiley categories. Did I say excellent job? Amazing work again. :D :)
 

DRE

Well-known member
#6
I've got one issue. When clicking the smilie in the TinyMCE Editor, it shows all the smilies instead of categorizing them like the smilie tab drop-down.

Other than that... still 5 stars though.
 

Kintaro

Well-known member
#7
I can't install it.

I uploaded all the files as usual and when I install the xml it say:
"The files associated with this add-on could not be found. Please upload them and try again."
I tried three times... I installed several other addon without problems.

The only thing is that my xf version i 1.1.2, could be that?

p.s. I have the happy place installed but disabled
 

Shelley

Well-known member
#8
I've just tried to install this on my live site and noticed there's no JS files but there's JS files in my test installation from testing this last week. I can't install this either on my live site and getting the following error
Code:
Mysqli statement execute error : Duplicate column name 'dc_smileymanager_display_order'
[LIST=1]
[*][B]Zend_Db_Statement_Mysqli->_execute()[/B] in [B]Zend/Db/Statement.php[/B] at line [B]297[/B]
[*][B]Zend_Db_Statement->execute()[/B] in [B]Zend/Db/Adapter/Abstract.php[/B] at line [B]479[/B]
[*][B]Zend_Db_Adapter_Abstract->query()[/B] in [B]Dc/SmileyManager/Install.php[/B] at line [B]83[/B]
[*][B]Dc_SmileyManager_Install->_installVersion1()[/B] in [B]Dc/SmileyManager/Install.php[/B] at line [B]63[/B]
[*][B]Dc_SmileyManager_Install::install()[/B]
[*][B]call_user_func()[/B] in [B]XenForo/Model/AddOn.php[/B] at line [B]214[/B]
[*][B]XenForo_Model_AddOn->installAddOnXml()[/B] in [B]XenForo/Model/AddOn.php[/B] at line [B]169[/B]
[*][B]XenForo_Model_AddOn->installAddOnXmlFromFile()[/B] in [B]XenForo/ControllerAdmin/AddOn.php[/B] at line [B]178[/B]
[*][B]XenForo_ControllerAdmin_AddOn->actionInstall()[/B] in [B]XenForo/FrontController.php[/B] at line [B]310[/B]
[*][B]XenForo_FrontController->dispatch()[/B] in [B]XenForo/FrontController.php[/B] at line [B]132[/B]
[*][B]XenForo_FrontController->run()[/B] in [B]/home/bbsmiley/public_html/admin.php[/B] at line [B]13
[/B]
[/LIST]
 

DRE

Well-known member
#9
I think I know what ya'lls problem is. Ya'll uploaded the files through FTP. I've been having issues with uploading addons to FTP for the past couple months.

These days I unzip the product, then zip parts of the addon folder and upload them directly to the server through cpanel and unzip them there in File Manager.

Basically there may be an issue with the addon creator's package or zip creation software whatever. That happened to me with some of ragtek's addons.
 

Shelley

Well-known member
#10
I can't install it.

I uploaded all the files as usual and when I install the xml it say:

I tried three times... I installed several other addon without problems.

The only thing is that my xf version i 1.1.2, could be that?

p.s. I have the happy place installed but disabled
I'm quite sure it's a problem with the add-on. I'm sure the author will be online shortly to provide a fix. I'd enable happyplace for now until he gets back online.
 

Shelley

Well-known member
#11
I think I know what ya'lls problem is. Ya'll uploaded the files through FTP. I've been having issues with uploading addons to FTP for the past couple months.

These days I unzip the product, then zip parts of the addon folder and upload them directly to the server through cpanel and unzip them there in File Manager.

Basically there may be an issue with the addon creator's package or zip creation software whatever. That happened to me with some of ragtek's addons.
I think it's missing the JS files. I uploaded my test site and it updated but on my live site i got the error so I'm almost sure it's because the JS files were not included.
 

DRE

Well-known member
#12
I think it's missing the JS files. I uploaded my test site and it updated but on my live site i got the error so I'm almost sure it's because the JS files were not included.
If it's working fine for me, then try doing what I said.

Overwrite the files on your server through File Manager in cPanel.
 

DRE

Well-known member
#17
The add-on installed fine through testing the way I've always installed add-ons. Reason why I'll wait for the author to get back as I see no reason to log into cpanel just to install an add-on.
When I had a problem with an addon it installed fine on my local installation. Nothing was missing. When I installed it on my live test board http://xen-seo.com it had missing js files.

Your issue looks like mine. Just trying to help.
 

Shelley

Well-known member
#18
When I had a problem with an addon it installed fine on my local installation. When I installed it on my live test board http://xen-seo.com it had missing js files.

Your issue looks like mine. Just trying to help.
Yeah I know you were and I appreciate that. Didn't mean anything by it I don't really want to start installling, overwriting files via cpanel if I can help it since through testing I was using the xf installation add-on system. I don't mind waiting though, i waited two years so it's no biggie. Thanks again 8thos. :)
 

DRE

Well-known member
#19
Alright well I got it working on my site http://www.8thos.com if anyone wants to see it in action.

I love how it automatically scrolls to tbe next category if you don't click the arrow. That is SO cool.

My only issue with that is after you reach the last category it stays there. Some people who aren't paying attention might assume it's the only category.
 

Sheldon

Well-known member
#20
I installed, everything went smooth, works perfect.

I did try it with the Add-On Auto-Installer, no go there.

I didn't have any files that needed to be overwritten either.