1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Unmaintained [dc] Smiley Manager 1.1.0

Smiley manager will help you manage your smilies by grouping them into categories.

  1. htdesignz

    htdesignz Active Member

    htdesignz submitted a new resource:

    [dc] Smiley Manager (version 1.0.0) - Smiley manager will help you manage your smilies by grouping them into categories.

    Read more about this resource...
    CoreIssue, Alien, Veer and 4 others like this.
  2. MOZ

    MOZ Well-Known Member

    Excellent work!
    8thos likes this.
  3. Allan

    Allan Well-Known Member

    Shelley will be happy (y)

    Thank you :)
    8thos likes this.
  4. DRE

    DRE Well-Known Member

    ^^^First person I thought of when I saw this addon was Shelley lol.

    Don't forget to uninstall The Happy Place before installing this or it will show two smilie tabs below the quick reply box!
  5. Shelley

    Shelley Well-Known Member

    Good advice. I'll repeat what 8thos said if you have the HAPPYPLACE ADD-ON installed ensure you uninstall this before Installing the DC Smiley Manager.

    Excellent work on this HTDesignz on developing this and embracing all the suggestions made and even more so fixing the issues that occurred. I cannot thankyou enough and appreciated the time and effort you put into this and making it available to us all. (y)

    Very happy with this, works absolutely great and enjoying the frontend category switcher to switch between smiley categories. Did I say excellent job? Amazing work again. :D :)
    htdesignz, yavuz and 8thos like this.
  6. DRE

    DRE Well-Known Member

    I've got one issue. When clicking the smilie in the TinyMCE Editor, it shows all the smilies instead of categorizing them like the smilie tab drop-down.

    Other than that... still 5 stars though.
  7. Kintaro

    Kintaro Well-Known Member

    I can't install it.

    I uploaded all the files as usual and when I install the xml it say:
    I tried three times... I installed several other addon without problems.

    The only thing is that my xf version i 1.1.2, could be that?

    p.s. I have the happy place installed but disabled
  8. Shelley

    Shelley Well-Known Member

    I've just tried to install this on my live site and noticed there's no JS files but there's JS files in my test installation from testing this last week. I can't install this either on my live site and getting the following error
    Mysqli statement execute error : Duplicate column name 'dc_smileymanager_display_order'
    [*][B]Zend_Db_Statement_Mysqli->_execute()[/B] in [B]Zend/Db/Statement.php[/B] at line [B]297[/B]
    [*][B]Zend_Db_Statement->execute()[/B] in [B]Zend/Db/Adapter/Abstract.php[/B] at line [B]479[/B]
    [*][B]Zend_Db_Adapter_Abstract->query()[/B] in [B]Dc/SmileyManager/Install.php[/B] at line [B]83[/B]
    [*][B]Dc_SmileyManager_Install->_installVersion1()[/B] in [B]Dc/SmileyManager/Install.php[/B] at line [B]63[/B]
    [*][B]call_user_func()[/B] in [B]XenForo/Model/AddOn.php[/B] at line [B]214[/B]
    [*][B]XenForo_Model_AddOn->installAddOnXml()[/B] in [B]XenForo/Model/AddOn.php[/B] at line [B]169[/B]
    [*][B]XenForo_Model_AddOn->installAddOnXmlFromFile()[/B] in [B]XenForo/ControllerAdmin/AddOn.php[/B] at line [B]178[/B]
    [*][B]XenForo_ControllerAdmin_AddOn->actionInstall()[/B] in [B]XenForo/FrontController.php[/B] at line [B]310[/B]
    [*][B]XenForo_FrontController->dispatch()[/B] in [B]XenForo/FrontController.php[/B] at line [B]132[/B]
    [*][B]XenForo_FrontController->run()[/B] in [B]/home/bbsmiley/public_html/admin.php[/B] at line [B]13
  9. DRE

    DRE Well-Known Member

    I think I know what ya'lls problem is. Ya'll uploaded the files through FTP. I've been having issues with uploading addons to FTP for the past couple months.

    These days I unzip the product, then zip parts of the addon folder and upload them directly to the server through cpanel and unzip them there in File Manager.

    Basically there may be an issue with the addon creator's package or zip creation software whatever. That happened to me with some of ragtek's addons.
  10. Shelley

    Shelley Well-Known Member

    I'm quite sure it's a problem with the add-on. I'm sure the author will be online shortly to provide a fix. I'd enable happyplace for now until he gets back online.
  11. Shelley

    Shelley Well-Known Member

    I think it's missing the JS files. I uploaded my test site and it updated but on my live site i got the error so I'm almost sure it's because the JS files were not included.
  12. DRE

    DRE Well-Known Member

    If it's working fine for me, then try doing what I said.

    Overwrite the files on your server through File Manager in cPanel.
  13. Shelley

    Shelley Well-Known Member

    I'm not overwriting any files through cpanel. I'll wait till the author gets back.
  14. DRE

    DRE Well-Known Member

    wtf lol

  15. Shelley

    Shelley Well-Known Member

    The add-on installed fine through testing the way I've always installed add-ons. Reason why I'll wait for the author to get back as I see no reason to log into cpanel just to install an add-on.
  16. Chris D

    Chris D XenForo Developer Staff Member

    This add-on should be made to be compatible with the Add-On Installer (IMHO) :p
    CFodder, yavuz, sforum and 1 other person like this.
  17. DRE

    DRE Well-Known Member

    When I had a problem with an addon it installed fine on my local installation. Nothing was missing. When I installed it on my live test board http://xen-seo.com it had missing js files.

    Your issue looks like mine. Just trying to help.
    Shelley likes this.
  18. Shelley

    Shelley Well-Known Member

    Yeah I know you were and I appreciate that. Didn't mean anything by it I don't really want to start installling, overwriting files via cpanel if I can help it since through testing I was using the xf installation add-on system. I don't mind waiting though, i waited two years so it's no biggie. Thanks again 8thos. :)
  19. DRE

    DRE Well-Known Member

    Alright well I got it working on my site http://www.8thos.com if anyone wants to see it in action.

    I love how it automatically scrolls to tbe next category if you don't click the arrow. That is SO cool.

    My only issue with that is after you reach the last category it stays there. Some people who aren't paying attention might assume it's the only category.
  20. Sheldon

    Sheldon Well-Known Member

    I installed, everything went smooth, works perfect.

    I did try it with the Add-On Auto-Installer, no go there.

    I didn't have any files that needed to be overwritten either.

Share This Page