1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Creating new Forum results in 504 timeout

Discussion in 'Troubleshooting and Problems' started by Warchamp7, Dec 18, 2013.

  1. Warchamp7

    Warchamp7 Active Member

    Recently migrated forum to a new server. Everything has been working fine as far as everything is known, except for creating a new forum. Trying to do so takes a while, then results in a 504 timeout from the server (On all pages) for a few moments, and the forum isn't created when it recovers.

    Any ideas?
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Is it shared hosting, VPS or dedicated?

    How many nodes and user groups do you have?
     
  3. Warchamp7

    Warchamp7 Active Member

    This is on a dedicated server.

    314 nodes. 33 usergroups
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    You may need to increase some of the values and do some server tuning with that many nodes and user groups.
     
  5. Mike

    Mike XenForo Developer Staff Member

    It's also worth noting that this process is changed in 1.2.
     
    Adam Howard likes this.
  6. Warchamp7

    Warchamp7 Active Member

    What values are you referring to? As far as tuning goes, I feel things are in a good place already.
     
    Last edited: Dec 19, 2013
  7. Brogan

    Brogan XenForo Moderator Staff Member

    In which case upgrading to 1.2 may be your best option then.
     
  8. Warchamp7

    Warchamp7 Active Member

    Is that really the only option at this point?
     
  9. Mike

    Mike XenForo Developer Staff Member

    Well the 504 timeout is coming directly from the server. The rebuild process will be time/CPU (and possibly memory) intensive, but it shouldn't wholly block other connections. If it is, it sounds like only one PHP process is being processed at a time (no task switching), which is likely to give bad performance in general. I'm guessing you're using a FastCGI server so you may want to look at that configuration (the number of processes/children available).

    Otherwise, 1.2 would help. It doesn't inherently change the amount of work that needs to be done -- there is a lot of recalculation to do -- but it's designed to allow that work to be split into multiple steps.
     
  10. Warchamp7

    Warchamp7 Active Member

    Hmm, I increased the timeout for php and nginx, and instead of the page 404'ing, I got a box pop up stating the error was in the javascript console.

    Is there somewhere in the admin panel I can raise that execution time limit?
     
  11. Jeremy

    Jeremy XenForo Moderator Staff Member

    No, that is a limit imposed by the server, not the software itself.
     
  12. Warchamp7

    Warchamp7 Active Member

    Ah, right. I tweaked php-fpm and not php. Silly me. Increased max execution time for PHP and all is well now.
     
    Last edited: Dec 19, 2013
  13. Mike

    Mike XenForo Developer Staff Member

    You may need to tweak both in that case.

    The changes in 1.2 do specifically relate to this issue though, so that's really what we'd recommend.
     

Share This Page