1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Search specific forum results in multiple forum results?

Discussion in 'Troubleshooting and Problems' started by cmeinck, May 7, 2013.

  1. cmeinck

    cmeinck Well-Known Member

    For some odd reason, when I select a specific forum to search, my site is showing results from other forums? Here's a screenshot of what I'm searching and I'm seeing results come back for the iPhone 4S forum, although I have only iPhone selected? If it makes a difference, I have the XF Search add-on installed.

    Screen Shot 2013-05-07 at 6.39.26 PM.png
  2. Brogan

    Brogan XenForo Moderator Staff Member

    I can't replicate that here or on my own forum.

    Can you post a link to your site so I can checK?
  3. cmeinck

    cmeinck Well-Known Member

    Sure, my site is everythingiCafe. Please try searching for iPhone 4S, but only use the 'iPhone' forum category.
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Try rebuilding your index:

    Admin CP -> Tools -> Rebuild Caches

    Search results are also cached. Run this query to empty the cache between searches:

    TRUNCATE TABLE xf_search;
  5. Jeremy

    Jeremy XenForo Moderator Staff Member

  6. cmeinck

    cmeinck Well-Known Member

    I think Jake's on it. I've been busy this afternoon moving threads out of the iPhone forum into specific model categories. Rebuilding caches should fix it. Thanks guys for the quick replies.

Share This Page