1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Constantly Plagued By Errors

Discussion in 'Troubleshooting and Problems' started by Cal, Sep 21, 2012.

Thread Status:
Not open for further replies.
  1. Cal

    Cal Well-Known Member

    Here's the latest one of my members has forwarded to me. Any ideas on what it is and how to fix it??

    1. Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 317
    2. Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
    3. Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 574
    4. Zend_Db_Adapter_Abstract->insert() in XenForo/Session.php at line 690
    5. XenForo_Session->saveSessionToSource() in XenForo/Session.php at line 431
    6. XenForo_Session->save() in XenForo/Controller.php at line 403
    7. XenForo_Controller->updateSession() in XenForo/Controller.php at line 350
    8. XenForo_Controller->postDispatch() in XenForo/FrontController.php at line 317
    9. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
    10. XenForo_FrontController->run() in /var/www/vhosts/politicalbuddies.com/httpdocs/index.php at line 13
    It happens the most often when users allow their accounts to idle and the system logs them off, but it happens sporadically while people use the site as well.
     
  2. Digital Doctor

    Digital Doctor Well-Known Member

    No error message before this ? ie. before the 1. ?

    Doesn't that give a security error message ?
     
  3. Cal

    Cal Well-Known Member

    I don't think so. That's exactly what the user sent me. I notice that error too but it comes and goes too fast for me to catch. He happens to use dial up speeds via his cell phone connection at times so he can usually catch bugs like this with time to spare. I don't think it gives a security error message. People have been complaining about random threads not letting them in because of "insufficient permissions" in areas where they have every permission to post and whatever.
     
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Yeah what's the error message? You posted the stack trace but not the actual error. Check the log:

    Admin CP -> Tools -> Server Error Log
     
    Chris D likes this.
  5. Cal

    Cal Well-Known Member

    I never did find the error message on that one in the logs. There's quite a few errors in there a day. Now worries when I catch the error, and I almost have, I'll be able to post it in it's entirety. In the meantime.....

    I uninstalled Xenporta because it wasn't doing anything for me. The index controller was set so xenporta was index and forums was /forum/. Now that xenporta is gone the forums load as index and /forum/ loads an error. Any way to fix that???

     
  6. Russ

    Russ Well-Known Member

    Are you using jakes route changer? I know he posted a fix for XenPorta users which you may need to delete.
     
  7. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That error is expected then because the route no longer exists.

    Speaking of my route changer addon:

    http://xenforo.com/community/resources/route-changer.447/

    ...you can use that addon to map "forum" to "index":

    forum -> index

    That makes it so the nonexistent route "forum" loads the existing route "index".
     
    Cal likes this.
  8. Cal

    Cal Well-Known Member

    Hey Jake I did that and this is what I got. I had forum in the old path and index in the new one. Did I do something wrong?

    fail.png
     
  9. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    It works in my testing. My guess is you have a bad .htaccess file. Try uploading XenForo's default htaccess file. Or I can take a look if you give me FTP and admin access.
     
  10. Cal

    Cal Well-Known Member

    I got it. I replaced the .htacces and it worked out. Thanks Jake yet again! :D
     
  11. Digital Doctor

    Digital Doctor Well-Known Member

    Title change: Constantly Plagued by my own Errors
    Site looks great BTW.
     
  12. Cal

    Cal Well-Known Member

    Not necessarily. No need to be cold about it. Don't reply if that's how you feel.
     
  13. Digital Doctor

    Digital Doctor Well-Known Member

    The title of the thread is misleading.
     
  14. Cal

    Cal Well-Known Member

    Please stop trolling the thread. Please and thanks.
     
Thread Status:
Not open for further replies.

Share This Page