• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 Can't upload files to forum

CyberAP

Well-known member
#1
I am having issue with file upload function. It seems that it can't access filesystem write rights.
Logs say:

XenForo_Exception: Failed to write the attachment file. - library/XenForo/DataWriter/AttachmentData.php:119
I set data and internal_data permissions to 0777, including subfolders. Plus I changed owner and group to the same user that runs nginx. Strangely but almost the same config works for my dev forum, but not for the main one. What can else be causing that error?
 

Mike

XenForo developer
Staff member
#4
No, you shouldn't do that. I'm just trying to see if you have some fixes that may help if the files are being moved across partitions (and 1.1.5 should have enough of that).

Can you upload avatars and add-on/style XML? I would expect another permission error to be logged if it were the standard permission stuff. It could be an issue reading the actual uploaded file.
 

CyberAP

Well-known member
#5
I can upload XML files in adminCP, but I can't update my avatar. Here is what I get in console:

object[type$="x-shockwave-flash"]:not([classid]),object[type$="futuresplash"]:not([classid]),embed[type$="x-shockwave-flash"],embed[type$="futuresplash"]{display:none !important}{"sizeCode":"m","maxWidth":96,"maxDimension":"height","width":228,"height":192,"cropX":9,"cropY":0,"urls":{"l":"data\/avatars\/l\/0\/1.jpg?1383673840","m":"data\/avatars\/m\/0\/1.jpg?1383673840","s":"data\/avatars\/s\/0\/1.jpg?1383673840"},"user_id":1,"avatar_date":1383673840,"cropCss":{"left":"-18px","top":"0px"},"message":"Upload completed successfully","_visitor_conversationsUnread":"1","_visitor_alertsUnread":"0"} xenforo.js?_v=f5fb58b1:280
(anonymous function) xenforo.js?_v=f5fb58b1:280
d.event.handle jquery-1.5.2.min.js:16
k.handle.m
 

Mike

XenForo developer
Staff member
#6
Try updating your avatar in the non-overlay version (account/avatar, or ctrl-click the avatar on the person details page).
 

CyberAP

Well-known member
#7
I get a redirect back to Personal Details page, avatar remains unchanged. There are no errors in console or in server error logs.