• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Fixed Cannot upload except from within album

Affected version
v2 beta 5

Mr Lucky

Well-known member
#1
I have an add media button at the top level (Media Gallery overview) but cannot upload from there (I get a permissions error)

However if I navigate into one of my albums I can upload.

Analyse permissions says I can upload media.

SafariScreenshot032.png

SafariScreenshot031.png
 

Mr Lucky

Well-known member
#2
I have just noticed that neither can I add media from my own Your Albums view, I have to actually click into an album before the Add media button allows me to upload
 
#3
I'm also getting what sounds like the same error. I can't create user albums at all unless it's inside of a category. Using v 2 beta 6
Screenshot_20171011-161813.png
 
#5
Not sure. I'm brand new to xenForo (after many years on phpBB). If it helps the dev's my error is on a nearly clean install of xenForo 2.0 beta 6. The only permission that I have changed is to disallow guests viewing the Forum. Everything else is default setting. I'm not planning on launching the form live for another week or so. So I don't mind trying new installs or anything else that might be of help.
 
#6
I just did a fresh wipe and install of beta 6 for both the core xenForo and the Media Gallery. Same issue.

@Mr Lucky have you ran the 1.1.14 Media Gallery with xenForo 2.0 with success?
 
#7
@Chris D I think I narrowed it down, still not sure how/why/ or what exactly is right, but I did a test install on a subdomain to play with it and I was able to duplicate the error, fix it, and break it. Hopefully this pattern helps your troubleshooting. I tested it on my live site and duplicated the a couple working options on there but did not help on the live. Nothing has media on the test site, live has one image each. Only other difference is that the live site has descriptions for the nodes, the test is blank (saved time typing haha)

I thought it might of had something to do with only having three (after all successful trials at 4 nodes. but the last one only has three) The only common theme I see is only 3 nodes with at least one container only. So I was able to fix/break on test site but not fix on live site... yet :)

Again, hope this helps. I'll keep playing with it.

notwork.JPG
notwork2.JPG
works.JPG
works2.JPG
works3.JPG
works4.JPG