1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Cannot embed images on SSL image proxy - "could not open temp file"

Discussion in 'Troubleshooting and Problems' started by jflory7, Oct 11, 2015.

  1. jflory7

    jflory7 Active Member


    I recently moved machines that my XenForo community was hosted on, and I have it running on a RHEL 7 box. I noticed recently that whenever I try to embed images in forum posts, I always get the missing-image image instead of what the picture I actually want (despite it showing properly in the forum editor and when I go to edit the post).

    When I went to test the image proxy URL, the AdminCP gave me this output:

    https://i.imgur.com/vujndEA.png could not be fetched or is not a valid image. The specific error message was: Could not open temp file xf-image-proxy://1318737d5aa770ce43126fb5c27b8775-561aa57259a99

    I tried searching for the issue but only found a thread from 2011, checked my site on WhyNoPadlock to see if it could pick anything up but it passed, I double- and triple-checked that I installed my SSL certificate correctly on the new machine, and I tried restoring SELinux context to the httpd configuration directory (no changes were necessary).

    Any idea what's going on? I feel like I've exhausted my resources and I'm not sure what's causing the issue. The two embedded pictures I am working with right now can be found here:

    The thread on my site where this is happening can be found here.

    Thanks in advance for any help anyone can provide!

    - jflory7​
  2. Mike

    Mike XenForo Developer Staff Member

    Can you check permissions on your internal_data directory and sub-directories? Specifically, I'm wondering if there are issues writing to internal_data/temp.
  3. Mike

    Mike XenForo Developer Staff Member

    Oh I just noticed SELinux. I would recommend disabling that temporarily. It generally causes problems in our experience.
  4. jflory7

    jflory7 Active Member

    Permissions are as follows:
    $ ls -Alh
    total 76K
    drwxrwxrwx.  7 jflory apache   96 Oct 11 20:19 data
    drwxrwxrwx.  6 jflory apache 4.0K Jul 19 02:57 internal_data
    I don't see why it would be interfering now when I was also using it on my old server as well. :/

Share This Page