1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Not a Bug Cannot change boardUrl

Discussion in 'Resolved Bug Reports' started by Floren, Nov 21, 2011.

  1. Floren

    Floren Well-Known Member

  2. Saeed

    Saeed Well-Known Member

    I hope you placed all your installation files in the /community folder as well, right?

    How can I move my installation to a different directory?
    Update the Board URL in the ACP -> Options -> Basic Board Information and move the files to the new directory. You may need to restart the server for the change to take effect.

    http://xenforo.com/community/threads/frequently-asked-questions.5183/#post-180455
     
  3. Floren

    Floren Well-Known Member

    Well, boardUrl is a variable that is inserted into templates and other useful locations through getRequestPaths() function:
    Code:
    	public function setRequestPaths()
    	{
    		$requestPaths = XenForo_Application::getRequestPaths($this->_request);
    		var_dump($requestPaths);
    
    		XenForo_Application::set('requestPaths', $requestPaths);
    	}
    No matter what I set into boardUrl, I still get the default values.
    Code:
    array(6) {
      ["basePath"]=>
      string(11) "/community/"
      ["host"]=>
      string(14) "domain.com"
      ["protocol"]=>
      string(4) "http"
      ["fullBasePath"]=>
      string(32) "http://domain.com/community/"
      ["requestUri"]=>
      string(11) "/community/"
      ["fullUri"]=>
      string(32) "http://domain.com/community/"
    }
    Right now the boardUrl is set to:
    Code:
    https://domain.com/community
    The secure https is completely ignored, even if my certificate is valid and properly installed.
    Common Name = www.axivo.com
    Subject Alternative Names = www.axivo.com, axivo.com
    Issuer = Starfield Secure Certification Authority
    Serial Number = 4B17C13FF73566
    SHA1 Thumbprint = 08EB150C779D96D963AD09A038D41360F3DEBC47
    Key Length = 2048 bit
    Signature algorithm = SHA1 + RSA (good)
    Secure Renegotiation: Supported

    Plus, isn't the boardUrl definitive on where the board is located?
    If the boardUrl is set to:
    Code:
    http://domain.com/forum
    the above listed array still shows /community as basePath.
     
  4. Floren

    Floren Well-Known Member

  5. Brogan

    Brogan XenForo Moderator Staff Member

  6. Floren

    Floren Well-Known Member

  7. Mike

    Mike XenForo Developer Staff Member

  8. Floren

    Floren Well-Known Member

    Thanks, Mike. Adding:
    fastcgi_param HTTPS on;

    solves the base href issues. Looking at Nginx configuration, the second option is redundant.
    I still get a slashed https as URL validation.
     
  9. Floren

    Floren Well-Known Member

    OK, all problems solved. This is how I fixed the issue, for other users:
    1) Set in Nginx the HTTPS param to on.
    2) Disable Twitter and Gravatar. (not needed anymore in 1.1.1)
    3) Set homePageUrl and boardUrl to https scheme.
    4) Set Google Maps URL to https scheme.
     
  10. Floren

    Floren Well-Known Member

    I still have a question related to current users who have Gravatars set as default. How do I remove them? I've built the user caches but I still see user avatars linked to gravatar.com site.
     
  11. Brogan

    Brogan XenForo Moderator Staff Member

    You will have to manually remove them in the ACP.
     
  12. Floren

    Floren Well-Known Member

    Actually, I just ran a query to reset the Gravatars:
    Code:
    UPDATE xf_user SET gravatar = '';
    Then, I've rebuilt the User Cache.
     
  13. Brogan

    Brogan XenForo Moderator Staff Member

    That's cheating ;)
     
  14. Floren

    Floren Well-Known Member

Share This Page