1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Browser Issue [Browser Bug/Worked Around] editor: not possible to delete text

Discussion in 'Resolved Bug Reports' started by erich37, Feb 6, 2011.

  1. erich37

    erich37 Well-Known Member

    I just tried to edit some text in one of my posts here at xenforo.com

    clicking edit, then the pop-up-editor opens.
    But I just could not delete the text. I highlighted the text, but I could not delete it.

    Somehow this editor is still buggy. I am using FF-browser.

    [mike test 1234]
     
  2. Mike

    Mike XenForo Developer Staff Member

    I've been unable to reproduce this with FF here (as you can see with my edits to your post). There was an IE issue where it would randomly not allow editing for a short time, but it would come back then.

    What FF version?
     
  3. FredC

    FredC Well-Known Member

    I have the same problem using FF v 3.6.13, although i cant say for sure if ive experienced it here (XF) But i know i have this issue on my own forums from time to time.. I almost always have to click more options or my edits will also stack like..
    w
    h
    a
    t

    i
    s

    g
    o
    i
    n
    g

    o
    n
    ?
     
  4. Sami

    Sami Well-Known Member

    I get this also when I include an empty line in selection and hit backspace, but it happens in TinyMCE's test box too so...
     
  5. erich37

    erich37 Well-Known Member

    Mike,
    I do have this issue all the time. Using Firefox/3.6.13

    When I close the Editor-window. Then click onto "Edit" again, then it works fine.
    So each time I need to open the Editor twice in order to edit my text....
     
  6. lightbox

    lightbox Active Member

    I can confirm the IE issue where editing a post isn't possible.
    Happens pretty often.

    Cheers,
    martin
     
  7. DSF

    DSF Well-Known Member

    I cannot reproduce this systematically. [​IMG]

    It's sometimes only. (FF 3.6.13)
     
  8. Alluidh

    Alluidh Well-Known Member

    Yes, it only happens in FF 3.6.13 and it is very easy to reproduce
     
  9. Mike

    Mike XenForo Developer Staff Member

    I'm not sure if I'd say that, as neither Kier nor I can reproduce the issue (in Windows or OS X).

    Anyone want to try recording a video of what happens?
     
  10. Vincent

    Vincent Well-Known Member

    Tried it once every ten minutes, but it seems like I cannot reproduce :(
     
  11. Dodgeboard

    Dodgeboard Well-Known Member

    I've seen this on my own site as well with Firefox 3.6.13. Seems sporadic.
     
  12. erich37

    erich37 Well-Known Member

    the trouble is that this "issue" gives the user an immediate "impression" that the website is not working properly. quite annoying issue.

    can you re-produce ?
     
    Vincent likes this.
  13. Alluidh

    Alluidh Well-Known Member

    Yes, I write a long text. Then I split the text, maybe in 3 or 4 parts. Then I insert some spaces between the parts. Now I mark part 3 (for example) and all spaces until the end of part two and press "delete" - Nothing has deleted and the cursor is at the end of part 2. If I mark part 3 and all spaces until the end of part two and press "back", everything is deleted.

    I'll try to make some screenshots - Never worked with video before

    EDIT - Funny, not be able to reproduce in RC2 ... (and after the last java update)
     
  14. erich37

    erich37 Well-Known Member

    I am still having this issue at this very website here at xenforo.com

    when I for example mark a certain text, then want to delete it. it just does not get deleted.
    I always encounter strange issues with both editors on editing of text, but not when writing new text. this editor here at the bottom of the page and also with the new editor.
     
  15. Sami

    Sami Well-Known Member

    This is what I see in Firefox (no quotes required).
    Now select text from one empty line between foos to the other and hit backspace.
     
  16. erich37

    erich37 Well-Known Member

    the issue is actually like this:

    marking a certain text blue, then hitting the backspace-key in order to delete the marked text.
    Deleting text with the backspace-key is actually not working.
     
  17. Alluidh

    Alluidh Well-Known Member

    OK, problem exist in RC3 too, but only in the "inline editor". If you switch with the "More Options..." button to the normal editor everything is fine.
     
  18. Mike

    Mike XenForo Developer Staff Member

    I did have this happen once, totally unexpectedly. I tried to paste some code in and it went to a completely different location and I couldn't delete the text. It wasn't reproducable unfortunately.
     
    FredC and erich37 like this.
  19. lightbox

    lightbox Active Member

    Can't reproduce it anymore.
    Still wonder why it happened but I'm happy it's gone. :)
     
  20. FredC

    FredC Well-Known Member

    Exactly the same problem except i usually don't catch it until i try to replace/edit the text and realize all my new/edited text has stacked one letter at a time

    unless something has changed the problem will strike again sooner or later.. Glad you've at least experienced it.. I tried to make a screen video and determined that wasn't gonna cut it , because it couldn't show the user actions just the result.
     

Share This Page