• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 2.0 Bounce connection error: cannot connect to host

#1
1517650244845.png

Server error logs

Code:
Zend\Mail\Protocol\Exception\RuntimeException: Bounce connection error: cannot connect to host ; error = fsockopen(): unable to connect to ssl://london.mxroute.com:993 (Connection timed out) (errno = 0 ) src/vendor/zendframework/zend-mail/src/Protocol/Imap.php:93
Generated by: Unknown account Feb 3, 2018 at 3:36 AM
Stack trace

Code:
#0 src/vendor/zendframework/zend-mail/src/Storage/Imap.php(205): Zend\Mail\Protocol\Imap->connect('london.mxroute....', 993, 'SSL')
#1 src/XF/EmailBounce/Processor.php(241): Zend\Mail\Storage\Imap->__construct(Array)
#2 src/XF/SubContainer/Bounce.php(15): XF\EmailBounce\Processor::getDefaultBounceHandlerStorage(Object(XF\Pub\App))
#3 src/XF/Container.php(28): XF\SubContainer\Bounce->XF\SubContainer\{closure}(Object(XF\Container))
#4 src/XF/SubContainer/Bounce.php(43): XF\Container->offsetGet('storage')
#5 src/XF/Job/EmailBounce.php(20): XF\SubContainer\Bounce->storage()
#6 src/XF/Job/Manager.php(241): XF\Job\EmailBounce->run(7.9999990463257)
#7 src/XF/Job/Manager.php(187): XF\Job\Manager->runJobInternal(Array, 7.9999990463257)
#8 src/XF/Job/Manager.php(76): XF\Job\Manager->runJobEntry(Array, 7.9999990463257)
#9 job.php(15): XF\Job\Manager->runQueue(false, 8)
#10 {main}

-------------

Previous ErrorException: fsockopen(): unable to connect to ssl://london.mxroute.com:993 (Connection timed out) - src/vendor/zendframework/zend-mail/src/Protocol/Imap.php:90
#0 [internal function]: Zend\Stdlib\ErrorHandler::addError(2, 'fsockopen(): un...', '/home2/ooozoo/p...', 90, Array)
#1 src/vendor/zendframework/zend-mail/src/Protocol/Imap.php(90): fsockopen('ssl://london.mx...', 993, 110, 'Connection time...', 30)
#2 src/vendor/zendframework/zend-mail/src/Storage/Imap.php(205): Zend\Mail\Protocol\Imap->connect('london.mxroute....', 993, 'SSL')
#3 src/XF/EmailBounce/Processor.php(241): Zend\Mail\Storage\Imap->__construct(Array)
#4 src/XF/SubContainer/Bounce.php(15): XF\EmailBounce\Processor::getDefaultBounceHandlerStorage(Object(XF\Pub\App))
#5 src/XF/Container.php(28): XF\SubContainer\Bounce->XF\SubContainer\{closure}(Object(XF\Container))
#6 src/XF/SubContainer/Bounce.php(43): XF\Container->offsetGet('storage')
#7 src/XF/Job/EmailBounce.php(20): XF\SubContainer\Bounce->storage()
#8 src/XF/Job/Manager.php(241): XF\Job\EmailBounce->run(7.9999990463257)
#9 src/XF/Job/Manager.php(187): XF\Job\Manager->runJobInternal(Array, 7.9999990463257)
#10 src/XF/Job/Manager.php(76): XF\Job\Manager->runJobEntry(Array, 7.9999990463257)
#11 job.php(15): XF\Job\Manager->runQueue(false, 8)
#12 {main}
Request state

Code:
array(4) {
  ["url"] => string(8) "/job.php"
  ["referrer"] => string(19) "https://mywebsite/"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(0) {
  }
}
Email Bounce Logs

Code:
No entries have been logged.
 
#6
My errors had gotten resolved shortly after this issue..

Make sure the ports needed are not blocked at the firewall (you may need assistance from your hosting company to be sure of this).
You resolved it with your host company also od do i have to do settings by myslf but Wich ones exactly ??
Thank you
 

Alien

Well-known member
#7
You resolved it with your host company also od do i have to do settings by myslf but Wich ones exactly ??
Since I was already discussing something with my hosting company, I mentioned it to them in the call and they had it done in 30 seconds. They just have to add whatever ports you require for your particular setup, and restart the firewall...
 
#8
Ok thank you !!
According to my message error it seems that the issue is from port 143 IMAP. But when i check my host it is already open look at the last one.


Capture d’écran 2018-02-24 à 14.51.44.png

I've opened a ticket with my host support !!
 

Tracy Perry

Well-known member
#9
What port have you configured XenForo to communicate via SMTP with? That is the port that needs to be open to connections outbound (at the least).
 
Last edited:
#10
What port have you configured XenForo to communicate via SMTP with? That is the port that needs to be open to connections outbound (at the least).
Good Question !!
I was thinking about it also. And yes i don't use the default Xenforo SMTP but Pepipost for my transactionnals emails. So I deactivate it and but the Xenforo SMTP with my host to see if i still avec these errors.
Thank you !!