• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Board URL

#1
Sorry for the dumb question but I installed XenForo successfully but how do I get it to appear at my url, e.g., www.example.com? No forums/, etc. I want the board to appear when someone goes to my home page which I have deactivated from appearing in the navigation bar.
 

Jeremy

Well-known member
#12
You can attempt to set your home page route to be forums, but I don't think that'll work the way you want since it defaults to forums. You can use a route filter to change it from forums to something else tho.
 

Tracy Perry

Well-known member
#16
In Options I set Board URL to http://radiofreemississippi.org. That should bring up my newly installed XenForo but it does not. Why not? And how do I get it to?
Maybe because you have an index.html present and it is taking precedence over index.php?

EDIT... just checked and index.html doesn't pull up a page. You may have a server mis-configuration present. If you add index.php onto the end of your domain the xenForo software pulls up - but has an error. And now it's saying it's not available.
 

Tracy Perry

Well-known member
#17
Make sure that your web server looks for index.php before anything else.
When you browse to your domain, this is the code being served up.
Code:
<html>
<head>
  <title>Radio Free Mississippi with Jim Giles</title>
</head>
<body bgcolor="#FFFFFF" topmargin="200" leftmargin="400" rightmargin="400" bottommargin="200">

<font face="verdana" size="14" color="red">

<div align="center"><h1>Radio Free Mississippi with Jim Giles</h1></div>


Radio Free Mississippi with Jim Giles has ceased broadcasting until Jim Giles is prepaid $20 million at which time he will resume broadcasting for a period of 10 years or until Jim Giles is prepaid a $100 per show rate.<p>

Mail check, money order, cashier’s check or cash to:<p>

Jim Giles<br>
173 Pear Lane<br>
Pearl, MS 39208<p>

<a href="http://youtu.be/BxroiTRg7Tg" target="_blank">Broken Arrow!</a><p>

</font>
</body>
</html>
You need to find where that's being served from and then check your server settings to change it to reflect your xenForo related (again, making sure that the server checks for index.php before index.html or index.htm.
 
#19
Thank you for your replies. I figured it out. I needed to delete my home.html file in my root directory and then my forum came up just fine.

Another question: I have several other urls which point to the same ip address but those other urls show error. The forum comes up but I see error on the page:

wwww.radiofreemississippi.org (Main)

wwww.rebelarmy.com (other)

???