Better Analytics

Better Analytics 3.1.1

No permission to download

Mackeral_Fillet

Well-known member
Hi,

I can't work out why one of my forum analytics are no longer tracking new visits. My forums are made up of about 30-40% of visits being new , this has reduced to less than a single percent. I've been trying to work out what is causing it but am out of ideas... Any thoughts?

Screen Shot 2017-04-24 at 21.19.09.png

Thanks,
 

digitalpoint

Well-known member
Could be a lot of things... could be third-party JavaScript code that is having the browsers do something different than your other sites (for example making periodic AJAX calls, which will reset GA session timeout timers) for example.

By what measurement are you determining that your user base is 30-40% new? That measurement might simply be different than how Google Analytics measures it.
 

Mackeral_Fillet

Well-known member
Thanks, not too sure how to troubleshoot further.

Older Analytics results we always around 30-40% new visits, and my other very similar forum niches are also this. 1% new users is way too low, we rank high on google...
 

Mackeral_Fillet

Well-known member
OK, might have fixed it. Think it was somehow related to the User-ID feature... I had that on, but creating a new 'View' as a test seems to have sorted it. I wonder if I somehow filtered a view to show only logged in members?
 

digitalpoint

Well-known member
That would make sense if you were only showing users with a User-ID... which would correlate into the vast majority of your logged in users being returning users (at least as far as how GA measures it). :)
 

kaieivindm

Well-known member
@digitalpoint

So I've been using the free Version of Better Analytics for XenForo quite a while. Has been working like a charm, but decided I needed some more functions. So I purchased the Product yesterday.

Since I wanted most out of the tool, I checked off everything I needed in the Xenforo settings panel. About 1 minute after installation and saved settings, I got like 120 sessions from the US, France and Brazil primarily and no real users. Just spam, crawlers, bots and whatnot.

So I checked the Bot filtering check Box in GA, which reduced the traffic logged in GA quite a lot. But I still get tons of these crawlers on my site today, which I did not even see With the free Version.

So basically, my question is why? Is it because I track more traffic now?

Bonus question, If I use IP Block Manager in CPANEL, for ip-ranges, will those still be tracked in GA?

//edit: answered on the plugin site.
 
Last edited:

AzzidReign

Well-known member
@digitalpoint
I'm not sure when the change occurred as it isn't a metric I really closely track but I'm no longer able to see the forum traffic breakdown. I'm not sure if this is due to some changes in gA (most likely). For example, I'm no longer seeing "custom variables" in the admin panel in gA. What I do see if Custom Definition now:
Egiy4Zq.png


And then the code looks different:
Code:
var dimensionValue = 'SOME_DIMENSION_VALUE';
ga('set', 'dimension1', dimensionValue);

Not sure if that has been updated in your code or not, I haven't had a chance to look tbh.
 

digitalpoint

Well-known member
@digitalpoint
I'm not sure when the change occurred as it isn't a metric I really closely track but I'm no longer able to see the forum traffic breakdown. I'm not sure if this is due to some changes in gA (most likely). For example, I'm no longer seeing "custom variables" in the admin panel in gA. What I do see if Custom Definition now:
Egiy4Zq.png


And then the code looks different:
Code:
var dimensionValue = 'SOME_DIMENSION_VALUE';
ga('set', 'dimension1', dimensionValue);

Not sure if that has been updated in your code or not, I haven't had a chance to look tbh.
Are you using a custom style by chance? There is a small amount of JavaScript that's inserted on the relevant pages that includes the page-specific tracking info for the dimensions.

Although it's added to a template that really probably doesn't change in custom styles. Specifically, it's within the page_container_js_head template. If you have a URL to your site I could probably check the page source for you.
 

NixFifty

XenForo developer
Staff member
Are you using a custom style by chance? There is a small amount of JavaScript that's inserted on the relevant pages that includes the page-specific tracking info for the dimensions.

Although it's added to a template that really probably doesn't change in custom styles. Specifically, it's within the page_container_js_head template. If you have a URL to your site I could probably check the page source for you.
Custom style, yeah.

JS seems to be getting injected fine:

Screen Shot 2017-06-21 at 23.36.16.png
 
@digitalpoint Just to make sure I understand everything correctly, the plugin is free to use on one site. You can also unlock bonus features for $50, which allows you to use it on up to five sites that you own. Question: What if we wanted to use it on more than five sites? How would that work, or would that not be possible?
 

digitalpoint

Well-known member
@digitalpoint Just to make sure I understand everything correctly, the plugin is free to use on one site. You can also unlock bonus features for $50, which allows you to use it on up to five sites that you own. Question: What if we wanted to use it on more than five sites? How would that work, or would that not be possible?
There isn't currently a licensing mechanism for more than 5 sites with the bonus features. You can use it on unlimited without the bonus features.
 

eberkund

Well-known member
Hi @digitalpoint will the version for XF2 require a new license? I am wondering whether or not I should purchase now or wait for XF2 to come out and buy then. If it is going to be a new license would you be open to providing upgrades for those who purchase after a certain date?

Thanks
 

digitalpoint

Well-known member
Hi @digitalpoint will the version for XF2 require a new license? I am wondering whether or not I should purchase now or wait for XF2 to come out and buy then. If it is going to be a new license would you be open to providing upgrades for those who purchase after a certain date?

Thanks
The Pro version will not require a new license (all licenses come with 12 months of free updates), although if you are looking for the XF2 version, might just want to hold off until such a thing actually exists and just use the free version until there is an XF2 version to be had.
 

RobParker

Well-known member
The Pro version will not require a new license (all licenses come with 12 months of free updates), although if you are looking for the XF2 version, might just want to hold off until such a thing actually exists and just use the free version until there is an XF2 version to be had.

I won't hold you to it but are we likely to see updates to your addons for XF2?
 

digitalpoint

Well-known member
I won't hold you to it but are we likely to see updates to your addons for XF2?
Probably not some of the less popular ones (or the ones that are features implemented in XF2 natively of course), but yes... Better Analytics will be rebuilt from scratch for XF2 with more features. There isn't a timeline on when it's going to be done though.
 

digitalpoint

Well-known member
The XF2 version should be brought up to feature parity with the WordPress version. Things like not needing to setup a Google API project, automatic configuration of Google Analytics account for various things (like setting up custom dimensions), widget support, management of Goals from admin area, support for experiments (A/B testing), client-side error tracking (like missing images, JavaScript errors), etc.

Screenshots are from WordPress version just to give you a general idea what I'm talking about...

1505170377684.png

1505170410337.png

1505170447742.png

1505170479283.png

1505170491004.png

1505170587426.png
 

Tealk

Well-known member
Hello

I use version 3.1.1 and get the following error.
It started yesterday without changing anything
Code:
Error Info
Unable to Connect to ssl://accounts.google.com:443. Error #110: Connection timed out - library/Zend/Http/Client/Adapter/Socket.php:235

Stack Trace
#0 /anzahcraft.de/library/Zend/Http/Client.php(973): Zend_Http_Client_Adapter_Socket->connect('ssl://accounts....', 443, true)
#1 /anzahcraft.de/library/DigitalPointBetterAnalytics/Helper/Reporting.php(100): Zend_Http_Client->request('POST')
#2 /anzahcraft.de/library/DigitalPointBetterAnalytics/Helper/Reporting.php(368): DigitalPointBetterAnalytics_Helper_Reporting::checkAccessToken()
#3 /anzahcraft.de/library/DigitalPointBetterAnalytics/Model/Analytics.php(204): DigitalPointBetterAnalytics_Helper_Reporting->getRealtime('rt:activeUsers', 'rt:pagePath', '-rt:activeUsers', 'rt:pagePath=~/i...')
#4 /anzahcraft.de/library/DigitalPointBetterAnalytics/CronEntry/Cron.php(15): DigitalPointBetterAnalytics_Model_Analytics->getRealtimeUsage()
#5 /anzahcraft.de/library/XenForo/Model/Cron.php(356): DigitalPointBetterAnalytics_CronEntry_Cron::runVeryOften(Array)
#6 /anzahcraft.de/library/XenForo/Deferred/Cron.php(24): XenForo_Model_Cron->runEntry(Array)
#7 /anzahcraft.de/library/XenForo/Model/Deferred.php(295): XenForo_Deferred_Cron->execute(Array, Array, 8, '')
#8 /anzahcraft.de/library/XenForo/Model/Deferred.php(429): XenForo_Model_Deferred->runDeferred(Array, 8, '', false)
#9 /anzahcraft.de/library/XenForo/Model/Deferred.php(374): XenForo_Model_Deferred->_runInternal(Array, 8, '', false)
#10 /anzahcraft.de/deferred.php(23): XenForo_Model_Deferred->run(false)
#11 {main}

Request State
Array
(
    [url] => https://anzahcraft.de/deferred.php
    [_GET] => Array
        (
        )

    [_POST] => Array
        (
            [_xfRequestUri] => /admin.php
            [_xfNoRedirect] => 1
            [_xfToken] => ********
            [_xfResponseType] => json
        )

)
 
Top