1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

beta1 --> beta2 failed on forum import

Discussion in 'Installation, Upgrade, and Import Support' started by steven s, Oct 21, 2010.

  1. steven s

    steven s Well-Known Member

    upgraded a clean beta1 version to beta2.
    Imported my v3 forum.
    beta1 had problems importing private messages. Beta2 imported them all.

    Got all the way to importing forums.
    Then page not found error.
    Imported again and now duplicate forums but still page not found error.

    I'll delete my core files and database and start all over.
    Just posting in case someone else got to this point.
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    I've moved this to installation and upgrade problems :)
     
  3. Mike

    Mike XenForo Developer Staff Member

    Forums were the key point that I haven't changed. How many forums do you have?

    The page not found error is very strange. I'm very curious as to what page it thinks it's redirecting to.
     
  4. steven s

    steven s Well-Known Member

    Thanks. Either didn't notice or was too excited about the update.
    Using beta1, my import stopped at exactly 1200 PMs stopped with "The requested page could not be found".
    Continue. Stopped at message 1600. Same error. Continue. Stopped at 2000. Error.
    The good news is beta2 fixed that. :)

    I am importing 92 categories, forums and links. Several are closed.
    35 were imported before "The requested page could not be found".
    Viewing the 35 in the node list, they where all left justified (not displaying sub forums correctly).
    Rebuilt cache, node list in the admin cp OK.
    The only forums visible are the two default ones.
    If I continue the same 35 will be imported.
     
  5. Mike

    Mike XenForo Developer Staff Member

    Is it possible for me to get admin and FTP access to where you're doing this import? That would allow me to debug it. It doesn't sound like a general timeout issue.
     
  6. steven s

    steven s Well-Known Member

    Sure. Use the contact us?
    Should I delete the database and start all over without importing?
    Keep in mind, it's importing my live database. :)
     
  7. Mike

    Mike XenForo Developer Staff Member

    You can use contact use or just PM me directly. If your import is currently stuck at the forums point, that would be ideal. :)
     
  8. Rjs37

    Rjs37 Member

    Forum Import could do with being changed into a stepped import like the other parts.

    I've got a lot of forums in the database I'm importing from (including quite a lot of old hidden ones). 479 records in total in the forum table of the vbulletin db. It's just taking absolutely ages (I changed my local's config so as to stop it from timing out) and with no idea of the progress you don't have a clue how long it's going to take. Mine has been going for close to an hour now and no sign of it stopping yet.

    EDIT: Imported 479 items. (1 hours 9 minutes 40.64 seconds)
     
  9. Rjs37

    Rjs37 Member

    Okay still getting the same error on importing thread/posts. I'm using the vbulletin 4 import, do I need to use the 3.7 import instead? The error I'm getting is below and as far as I can tell is related to unexpected characters.

     
  10. g0rn

    g0rn Well-Known Member

    Be sure to use the latest version of the vb4 importer, it was updated to fix this as far as I know.
     
  11. Rjs37

    Rjs37 Member

    Ah, Thanks. I made the assumption that the VB4 Importer was built ontop of the 3.7 one and just imported extra stuff. Didn't realize it replaced the import functionality entirely.
     

Share This Page