Resource icon

[bd] Rotating Ads 2.0

No permission to download

Dr.Who

Active member
How does the permission set?
Okay, I logged out and see it!!! Wahoo!!!!!

What should the permissions look like for everyone to see it, I have just left them blank right now.

It seems you can only see it when logged out. I've tried variations and can't seem to get it right so everyone can see it logged in or not.
 

Dr.Who

Active member
For everyone to see it just leave everything blank. Here's a permission where only logged in members could see it.

View attachment 110371
I can assure you I left everything blank and no go, only could see it when logged out. No idea why though as that's what I read in this thread as well.

I just figured it out though, I selected every user group!! :)
upload_2015-7-4_16-42-56.png

Also, a note to UI.X users, to see it above the breadcrumb on the forum index page, you must remove the welcome block out from that area.

Thanks for your help and replys clove, much appreciated man. :)
 
Last edited:

clove28

Active member
I can assure you I left everything blank and no go, only could see it when logged out. No idea why though as that's what I read in this thread as well.

I just figured it out though, I selected every user group!! :)
View attachment 110372

Also, a note to UI.X users, to see it above the breadcrumb on the forum index page, you must remove the welcome block out from that area.

Thanks for your help and replys clove, much appreciated man. :)
That's weird. If I want to show it to everyone, I just need to leave everything blank. Anyway, you found an alternative. ;) You're welcome!
 

hcmagix

Active member
Im looking for an solution to change / slide different banners on site refresh or time intervall. Can I use this addon to replace the original XF Banner?
 

xfrocks

Well-known member
I installed the add-on but can't find it within options, appearance, nor styles.
If you are not the super admin, you need to add "Manage Rotating Ads" permission to your account. Afterwards, you should be able to see Rotating Ads navigation link under Appearances AdminCP section.
 
I didn't notice there was an update and was using version 1.6.2 previously.

I have updated to version 2.0 today and now these server errors are showing up:

Server Error Log
Error Info
ErrorException: Fatal Error: Class 'RotatingAds_Engine' not found - library/RotatingAds/Listener.php:18
Generated By: Unknown Account, A moment ago
Stack Trace
#0 [internal function]: XenForo_Application::handleFatalError()
#1 {main}
Any idea what could be wrong? Thank you!
 
Yep, the file is there:

domain.org/library/RotatingAds/Engine.php

Again, the error started to show up after the upgrade of Rotating Ads to version 2.0
 
Top