1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. This forum has been archived. New threads and replies may not be made. All add-ons/resources that are active should be migrated to the Resource Manager. See this thread for more information.

Automatic RSS Thread Generator

Discussion in 'Add-on Requests [Archive]' started by HoddzDJ, Nov 24, 2011.

  1. HoddzDJ

    HoddzDJ Active Member

    I'm not sure if this has been requested before, if there is an add-on for it already or if it is built into the core of XenForo but I have searched on this forum and in my admin control panel for it and couldn't find what I was looking for!

    Basically, I'd like a RSS thread generator that posts new threads from blog posts on WordPress. I could then move from using the comments and getting shed loads of spam and instead have the link to come over to my (much more powerful) forum.

    Any help on the matter would be much appreciated!
  2. Mikey

    Mikey Well-Known Member

    Have you tried yoursite.com/xenforo/admin.php?feeds/ ?
  3. sforum

    sforum Active Member

    i just tried this, and now my forum is completely borked :( all i get is:

    Server Error

    Undefined offset: 0
    1. XenForo_Application::handlePhpError() in Yilmaz/TopThread/Model/TTopThread.php at line 32
    2. Yilmaz_TopThread_Model_TTopThread::Yilmaz_TopThreadArray() in Yilmaz/TopThread/Controller/Public.php at line 10
    3. Yilmaz_TopThread_Controller_Public->actionIndex() in XenTrCom/TopPoster/Controller/Public.php at line 6
    4. XenTrCom_TopPoster_Controller_Public->actionIndex() in XenTrCom/TodayBirthday/Controller/Public.php at line 6
    5. XenTrCom_TodayBirthday_Controller_Public->actionIndex() in XenForo/FrontController.php at line 310
    6. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
    i have tried deleting all RSS feeds from the admin Registered Feeds, as well as deleting the node/forum that it fed into, but i still get the above :(

    can someone please help? I really need to get my forum back!
  4. Brogan

    Brogan XenForo Moderator Staff Member

    That's related to an add-on: Yilmaz/TopThread

    Try disabling/uninstalling it.
  5. sforum

    sforum Active Member

    bingo! thanks brogan, as usual..

    thing is, it worked fine before i tried to add an RSS feed via ACP > Applications > Feeder

    once it broke, i deleted all XML feeds from the above screen, then deleted the node/forum that it fed into.. shouldn't this revert the xenforo installation to exactly how is was before i added the XML feed? i.e. it should have just worked again?

Share This Page