1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Attachment uploads stuck at 100%

Discussion in 'Troubleshooting and Problems' started by Smooth, Jun 1, 2011.

  1. Smooth

    Smooth Active Member

    Hey all.

    Trying to upload image attachments to the forum and it keeps getting stuck at 100% (prior to offering thumbnail/full size insert.

    Can anyone offer a hand? Have tried with different attachment settings in terms of maximum mb and physical size...

    Many thanks in advance for your help.
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Have you tried editing the .htaccess file to see if that resolves it?

    Code:
    # Mod_security can interfere with uploading of content such as attachments. If you
    # cannot attach files, remove the "#" from the lines below.
    # <IfModule mod_security.c>
    # SecFilterEngine Off
    # SecFilterScanPOST Off
    # </IfModule>
     
    DarkUnderlord likes this.
  3. borbole

    borbole Well-Known Member

    Did you do any recent changes to your forum before getting this?

    P.s. Can you disble the Use Flash Uploader option and try to upload a attchement and copy/paste here the error that it will throw?
     
  4. Smooth

    Smooth Active Member

    Hiya Brogan... Will try the .htaccess...

    This evening I have switched on friendly URLs... I just switched them off and uploads work perfectly...

    Will try again with them switched on and the htaccess modded as above?
     
  5. Smooth

    Smooth Active Member

    Borbole - seems that friendly URLS are the cause... not sure why though...
     
  6. borbole

    borbole Well-Known Member

    I haven''t tried this myself. Can you try it at a fresh forum and see if it will happen again?
     
  7. Smooth

    Smooth Active Member

    Non Flash uploader works fine with Friendly URLS....

    Flash uploader with friendly URLS gets stuck at 100%?!
     
  8. Smooth

    Smooth Active Member

    Definitely the flash uploader/friendly urls combo.... sorry to be a pain Xen Peeps...
     
  9. borbole

    borbole Well-Known Member

    Why don''t you start a ticket about this so one of the staff here can take a look into it?
     
  10. Smooth

    Smooth Active Member

    Thanks Borbole.. Willdo.... I try and hold off starting tickets as it is usually me doing something wrong/dumb! :)

    Have started a ticket. Thank you for your assistance :)
     
  11. Digital Doctor

    Digital Doctor Well-Known Member

    Same problem with all browsers ?
    FireFox ? Chrome ? IE ?
    Are the files to be uploaded on the local drive or a networked drive ?
     
  12. TBolley

    TBolley Active Member

    any news for flash uploader, if some fix comming soon to get work with htaccess ?
     
  13. Blandt

    Blandt Well-Known Member

    This issue is a permission issue. Make sure to chmod 777 your data folder
     
  14. TBolley

    TBolley Active Member

    nope, with non flash uploader works perfect.
     
  15. Smooth

    Smooth Active Member

    TBolley - we had the same problem. It was sorted by Xen staff by a tweak of the htaccess when i started a support ticket :)
     
    DohTheme likes this.
  16. dieketzer

    dieketzer Well-Known Member

    what was the fix? i am having this problem myself.
    was it the code brogan posted earlier?
     
  17. Ingenious

    Ingenious Well-Known Member

    I have this problem on my test forum but not when uploading here. On my installation I turned off the flash uploader in the settings and fell back to the standard one which works fine. I'd be interested to know if there is another way around this rather than force everyone to use the basic uploader :)
     
  18. ankurs

    ankurs Well-Known Member

    is ur test forum dir pass protected ? then that is the problem
     
    Ingenious likes this.
  19. Ingenious

    Ingenious Well-Known Member

    Yes it is! I just tried it without the password protection (as the live site would be) and it worked.

    Brilliant - and thanks very much for helping fix it :)
     
  20. JoeMurray

    JoeMurray Member

    TBolley, could you please write down the ".htacces tweak"? I'm also being able to upload attachments with the flash uploader off, but getting stuck at 100% with the flash uploader on. Also if it matters, i'm not being able to reproduce the flash loader/friendly urls combo :S
     

Share This Page