1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Attachment upload stuck @ 100%

Discussion in 'Troubleshooting and Problems' started by Lu Kas, Jul 19, 2011.

  1. Lu Kas

    Lu Kas Active Member


    i searched the forum, but i cant find the solution. a member at my board tried to post a picture and told me that the upload get stuck at 100%. i couldnt belive it so i tried myself and ... i can upload many pictures, and xls and pdf but not everything.

    sometimes it wont work and if there is a file thats not working, it will never work with this file. i can open the picture in photoshop and safe it with a different extension but this will change nothing.

    i uploaded these 3 pictures (jpg, png, gif) to try the upload here and as you can see it worked.

    i disabled all addons, but this wont go away. there are no notifications in the error log. System is 1.0.4 no outdated templates. Changing to the default theme wont change anything.

    i read this http://xenforo.com/community/threads/attachment-upload-fails-sometimes.17752/ and http://xenforo.com/community/threads/attachment-uploads-stuck-at-100.16572/#post-218070

    Attached Files:

  2. Brogan

    Brogan XenForo Moderator Staff Member

    Can you host the file somewhere so I can test it on my installation and here?
  3. Lu Kas

    Lu Kas Active Member

  4. Brogan

    Brogan XenForo Moderator Staff Member

    As a test can you try disabling mod security?
    You need to edit the .htaccess file to do that.

    #    Mod_security can interfere with uploading of content such as attachments. If you
    #    cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    #    SecFilterEngine Off
    #    SecFilterScanPOST Off
    I don't think it will make any difference but it's worth a try.
  5. Lu Kas

    Lu Kas Active Member

    tried this before, not changeing anything
  6. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  7. Lu Kas

    Lu Kas Active Member

    i gave it a try, but as i dont have mod_fcgid it there was no change

  8. Lu Kas

    Lu Kas Active Member

  9. Lu Kas

    Lu Kas Active Member

  10. ProCom

    ProCom Active Member

    **** FIXED *****

    I recently moved hosting companies from one VPS to Linode. After the move everything was working fine, but I started having members complaining that some images were not uploading properly.

    They would upload an attachment (image) and the progress bar would hit 100% and then nothing would happen.

    After a bunch of researching, I changed the following settings for PHP and MySQL to match my previous VPS. I'm unfortunately not sure which one was successful in fixing the problem, but wanted to post here (and a few other related threads) to share that this worked for me!

    pico /usr/local/lib/php.ini
    memory_limit = from 32M to 158M

    pico /etc/my.cnf
    max_allowed_packet=268435456 to max_allowed_packet=64M
    wait_timeout=10 to 45

    (make sure to restart your services after you make the changes)
    Last edited: Mar 8, 2016

Share This Page