1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Server Issue Attachment upload freezing at 100% using the Flash uploader

Discussion in 'Resolved Bug Reports' started by Brogan, Oct 6, 2010.

  1. Brogan

    Brogan XenForo Moderator Staff Member

    Using the Flash uploader results in uploads freezing at 100%.

    I tried with various file types; png, txt, jpg and it's the same for all.

    The normal uploader works fine.
  2. Fred.

    Fred. Well-Known Member

    I have the same problem :confused:

    I tried with Firefox 3.6.10 and the lastest version of chrome (for mac)
  3. dmnkhhn

    dmnkhhn Active Member

    Strange... I have a screenshot that I can't upload, others work just fine.

    I think it's because of the size?! The one in question is 270 kb large, the one that works is only 123 kb large.
  4. dutchbb

    dutchbb Well-Known Member

    Same problem...


    As you can see, layout is also changed at 100%.

    Additional info:
    File: .jpg , 258KB

    Browser: Safari 5.0.2
    OS: OS X 10.6.4
  5. Omri.L

    Omri.L Active Member

    It happened for me too, but I talked with my host because I know they have mode_security on, and when they turned it off, the problem was fixed.
    Brogan likes this.
  6. dutchbb

    dutchbb Well-Known Member

    Solved it indeed.

    For others: create a .htaccess file in the root of your domain with the following content:
    SecFilterEngine Off
    @devs: right before the upload bar reaches 100%, the layout still looks bad (like in the screenshot of post #4).
  7. Brogan

    Brogan XenForo Moderator Staff Member

    Many thanks Omri.L, that solved the problem :)

    Mike still wants to do some more debugging on this issue so he wants to leave it here for now.
  8. Scott

    Scott Active Member

    Finding out what caused this would be awesome, mod_security is a good idea.
  9. Omri.L

    Omri.L Active Member

    You're very welcome :)
  10. Mike

    Mike XenForo Developer Staff Member

  11. dutchbb

    dutchbb Well-Known Member

    I have this problem again now, even with SecFilterEngine Off :confused:
  12. RobParker

    RobParker Well-Known Member

    Also seeing this problem. Some users report it sticks at 100%, others that it doesn't move from 0%.
  13. ProCom

    ProCom Active Member

    **** FIXED *****

    I recently moved hosting companies from one VPS to Linode. After the move everything was working fine, but I started having members complaining that some images were not uploading properly.

    They would upload an attachment (image) and the progress bar would hit 100% and then nothing would happen.

    After a bunch of researching, I changed the following settings for PHP and MySQL to match my previous VPS. I'm unfortunately not sure which one was successful in fixing the problem, but wanted to post here (and a few other related threads) to share that this worked for me!

    pico /usr/local/lib/php.ini
    memory_limit = from 32M to 158M

    pico /etc/my.cnf
    max_allowed_packet=268435456 to max_allowed_packet=64M
    wait_timeout=10 to 45

    (make sure to restart your services after you make the changes)

Share This Page